1 Reply Latest reply on Apr 11, 2006 3:13 PM by Pat Osterday

    No ClassLoaders found

    Pat Osterday Newbie

      On Friday I had an EJB3 app with a few entity and session EJB3s working fairly well on JBoss 4.0.4RC1. This morning I tried to redeploy the app and now I'm get a "No ClassLoaders found" error. I have no idea what could have changed - I went ahead and tried the JBoss AS 4.0.4CR2 release, but still no luck. Any ideas why I suddenly started getting these messages?

      I'm deploying an ear that contains the jar with the EJB3s and also a war file for the web app. I have <loader-repository>ea-us:app=ejb3</loader-repository> in my jboss-app.xml file.

      Thanks!

        • 1. Re: No ClassLoaders found
          Pat Osterday Newbie

          I could never figure out the what the problem was here. The sample from LaLiLuna still worked as did the EJB3Trail.ear. I really have no clue what the problem was - maybe something in MyEclipse or Eclipse or JBoss, but it was really hosed - even stripping it down to the bare ejbs didn't help. Creating a new project with the same source files worked. I checked everything I could - deconstructing the ear/jar, hex edit looking at the classes, looking at the project files - I hate when these problems come up. Very odd!