1 Reply Latest reply on Oct 25, 2006 4:47 PM by John Gilbert

    No LoginModules configured for java:

    John Gilbert Apprentice

      I am using the embedded container and setting the security-domain in the jboss.xml file. when i set it up like this

      <security-domain>java:/jaas/other</security-domain>


      i get the following exception:

      Caused by: javax.security.auth.login.LoginException: No LoginModules configured for java:
       at javax.security.auth.login.LoginContext.init(Unknown Source)
       at javax.security.auth.login.LoginContext.<init>(Unknown Source)
       at javax.security.auth.login.LoginContext.<init>(Unknown Source)
       at org.jboss.security.plugins.SubjectActions$LoginContextAction.run(SubjectActions.java:132)
       at java.security.AccessController.doPrivileged(Native Method)
       at org.jboss.security.plugins.SubjectActions.createLoginContext(SubjectActions.java:236)
       at org.jboss.security.plugins.JaasSecurityManager.defaultLogin(JaasSecurityManager.java:586)
       at org.jboss.security.plugins.JaasSecurityManager.authenticate(JaasSecurityManager.java:521)
       at org.jboss.security.plugins.JaasSecurityManager.isValid(JaasSecurityManager.java:330)
       at org.jboss.aspects.security.AuthenticationInterceptor.authenticate(AuthenticationInterceptor.java:125)
       at org.jboss.aspects.security.AuthenticationInterceptor.invoke(AuthenticationInterceptor.java:67)
       ... 31 more
      



      if i set it up like this

      <security-domain>other</security-domain>


      then it works in the embedded container but not in the app server.

      is this a bug or am i missing something?