4 Replies Latest reply on Jan 22, 2009 11:38 AM by Brendan Farragher

    Talikng to Remote EJBs in 4.2.1 from 4.0.5

    gum naam Newbie

      I have 2 jboss server instances , one is running 4.2.1, and has certain stateless session EJB3s.
      The other is 4.0.5, which calls these SLSBs. The 4.0.5 has been installed using the JEMS installer, and selecting the EJB3 option. (so it has all the necessary ejb3 related jar files).

      But when code running in 4.0.5 calls SLSBs in 4.2.1 I get the following exception trace.


      javax.naming.CommunicationException [Root exception is java.io.InvalidClassException: org.jboss.ejb3.session.BaseSessionRemoteProxy; local class incompatible: stream classdesc serialVersionUID = 8310915813626447181, local class serialVersionUID = 2609262789016232311]
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:722)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:587)
      at javax.naming.InitialContext.lookup(InitialContext.java:351)
      at
      ....


      If instead of 4.2.1 , I run 4.0.5 for the SLSBs , then every thing works perfectly.

      I tried running 4.2.1 with -Djboss.remoting.pre_2_0_compatible=true & jboss.remoting.version=1 as per 4.2.x release notes, for compatibility between 4.2.x and 4.0.x, but no luck.

      Any clues as to how I can make 4.0.5 ejb3 client talk to 4.2.x ejb3 ?

      thanks