3 Replies Latest reply on Nov 16, 2007 6:18 AM by Carlo de Wolf

    jbossall-client.jar incompatible between 421 and 422

    Ed Xu Newbie

      I have an stateless EJB3 deployed in jboss-4.2.2GA, when I use jbossall-client.jar from jboss-4.2.1 to call this EJB, then I found:

      javax.naming.CommunicationException [Root exception is java.io.InvalidClassException: org.jboss.ejb3.remoting.BaseRemoteProxy; local class incompatible: stream classdesc serialVersionUID = -2711693270411201590, local class serialVersionUID = 1126421850898582900]
       at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:724)
       at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:589)
       at javax.naming.InitialContext.lookup(InitialContext.java:351)
      ......
      
      


      After I replaced the jbossall-client.jar with jboss-4.2.2, it works fine. And I tested the case for call jboss-4.2.1 EJB3 by jbossall-client.jar from jboss-4.2.2, the same exception occured.
      My question is, I need to make EJB3 call for two version of jbossAS in one Application, is that possible to use a single jbossall-client.jar?