0 Replies Latest reply on Nov 17, 2007 9:23 AM by Ed Xu

    422GA remoting conflicts with -Djboss.remoting.pre_2_0_compa

    Ed Xu Newbie

      In my last topic http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4105325
      , I found jbossall-client.jar conflicts between 421 and 422 AS, that's a serialVersionUID bug. And I continue to test other version clients for Jboss 422 AS, and still have problem in Jboss 405 case.
      I use the flag -Djboss.remoting.pre_2_0_compatible=true on the JBoss 4.2.2 side to interoperate with Jboss 4.0.5GA client, and the client can call 422 EJB3 successfully. But after that, I found another client using 422 jbossall-clent.jar can not call the EJB3 any longer, the following exception occured:

      javax.naming.CommunicationException [Root exception is java.io.InvalidClassException: org.jboss.remoting.InvokerLocator; local class incompatible: stream classdesc serialVersionUID = -2909329895029296248, local class serialVersionUID = -4977622166779282521]
       at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:780)
       at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:627)
       at javax.naming.InitialContext.lookup(InitialContext.java:351)
      ......
      

      And I remove the flag -Djboss.remoting.pre_2_0_compatible=true, it works fine, of course the jboss 405 client failed as well.
      It seems that when using -Djboss.remoting.pre_2_0_compatible=true, the jboss remoting 2.0 becomes incompatible with 422 AS, I think that's a bug of jboss 422, maybe a jboss remoting bug also.