0 Replies Latest reply on Dec 10, 2007 3:05 PM by sim wong

    Please help~~deployment of webservice

    sim wong Newbie

      HI all,

      I am using jboss 4.0.4, jwsdp-2.0 and jbpm-bpel 1.1 beta 3. I have install everything needed to run the web service. after the installation, i deploy the hello example in the folder of jbpm-bpel.
      I can see the hello service in this link
      http://localhost:8080/jbossws/services

      then , i click the link http://localhost:8080/hello/greeter?wsdl
      then nothing is shown up in the browser. i am using safari as my browser.
      Is that suppose to see something after clicking the link?

      and i start my web service by going to link http://localhost:8080/hello/greeter
      it throws an exception

      HTTP Status 500 -

      type Exception report

      message

      description The server encountered an internal error () that prevented it from fulfilling this request.

      exception

      org.jboss.util.NotImplementedException: HTTP GET not supported
      org.jboss.ws.server.ServiceEndpointServlet.doGet(ServiceEndpointServlet.java:95)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:697)
      javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
      org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
      note The full stack trace of the root cause is available in the Apache Tomcat/5.5.17 logs.

      Did i do something wrong? Can anyone tell me why it throws exception? And How to fix the problem?

      Thanks a lot!!!!!

      sim