1 Reply Latest reply on Jun 12, 2008 3:44 AM by jaikiran pai

    Installing EJB 3.0 RC6 - PFD

    kiran kumar Newbie

      Hi All,

      In the instructions to install EJB 3.0 RC6 for jboss-4.0.3SP1
      there is a warning given,

      Because you patched 4.0.3SP1, the client jars in the jboss-4.0.3SP1/client directory will be invalid. Build your client classpath from:
      jboss-4.0.3SP1/lib
      jboss-4.0.3SP1/server/all/lib
      jboss-4.0.3SP1/server/all/deploy/ejb3.deployer
      jboss-4.0.3SP1/server/all/deploy/jboss-aop-jdk50.deployer

      I did not get this.

      Can anybody please clarify this.

        • 1. Re: Installing EJB 3.0 RC6 - PFD
          jaikiran pai Master

          Whenever you write a remote client application (like a standalone java client) which accesses JBoss (ex: for using the EJBs deployed on JBoss), in the client classpath you usually place/refer to the jboss jars present in %JBOSS_HOME%\client folder. This warning message states that instead of using the jboss jars present in the %JBOSS_HOME%\client folder, you will have to use the ones from those listed folders.