2 Replies Latest reply on Nov 25, 2008 5:09 PM by Chris Burnley

    EJB3 Session Bean as 2.1 Service

    Chris Burnley Newbie

      I'm deploying a remote ejb3 service (4.2.3) that needs to be called by a legacy ejb 2.1 (4.0.3) client.

      I've declared the bean with @Remote and @RemoteHome, and added container-configuration in a jboss.xml but it seems as though the service is still exposed as a ejb3 service because I get these types of exceptions:

      java.io.InvalidClassException: org.jboss.ejb3.session.BaseSessionRemoteProxy; local class incompatible: stream classdesc serialVersionUID = 831091
      5813626447181, local class serialVersionUID = 2609262789016232311


      which would imply that it is not really a 2.1 view of the service because it uses ejb3 proxy classes, making it incompatible with the 4.0.3 client.

      Is it even possible to do this with jboss ?