2 Replies Latest reply on Aug 24, 2006 7:46 PM by vivek v

    Can not open socket connection on Linux box using Transporte

    vivek v Newbie


      I am running server on linux and client on windows. Here is the code,

      Server Side,

       public static String locatorURI = "socket://localhost:5400";
       transportServer = TransporterServer.createTransporterServer(getLocatorURI(), new ClientAPIImpl());

      Client Side,

       private String locatorURI = "socket://";
       orderService = (IClientAPI) TransporterClient
       .createTransporterClient(locatorURI, IClientAPI.class);

      The program runs fine if both Client and Server are on the same box (either linux or windows), but if the server is on linux and client on windows I am not even able to ping its port (5400). Client just fails with not able to get connection error.

      I ran "netstat -an" on the server box and I do see server listening at port 5400. I even explicitly opened 5400 using iptables, but still when I run "telnet 5400" from my client machine it fails.

      Does anyone knows if I need to any other configuration on my server box for this remote connection to work?

      Thanks for any help.