1 Reply Latest reply on Jun 1, 2007 4:11 AM by Ron Sigal

    turn off options in twiddle

    Steve Terpening Newbie

      Hi. We're trying to run shell scripts to remotely twiddle our server, and some of our MBeans have attributes with hyphens(-) in them. Twiddle keeps interpreting them as twiddle options, and failing. We tried using -- (stop processing options), but we don't think it works.

      Can anyone tell us what's wrong with this cmd line?:

      twiddle.sh -s myserver -- set jboss.MyMBean AttrName "-value myvalue"

      We've also tried escaping the "-value" with \, and ', which only results in the escape char being passed and assigned to the AttrName. We've also tried moving the -- after the 'set' cmd and to the end, also didn't work.

      Any ideas?