4 Replies Latest reply on Jan 22, 2009 8:56 PM by KRISHNA P

    Remoting 2.4.0.GA is now available

    Ron Sigal Master

      JBossRemoting 2.4.0.GA is now available. This is a major incremental release, that resolves about 160 JIRA issues, including 76 bug fix issues and 28 feature issues. It is meant to be binary compatible with the previous major release, currently at 2.2.2.SP7, and configurably wire compatible with any release back to 1.4.3.GA.

      Among the new features are:

      - Support for multihome servers [JBREM-643]
      - Safe to run with installed security manager [JBREM-934],[JBREM-977],[JBREM-978],
      - Better support for IPv6 addresses [JBREM-864], [JBREM-865]
      - Improved connection monitoring [JBREM-888], [JBREM-891]
      - Server gets client address in invocations [JBREM-758]
      - Support for server configuration by microcontainer injection [JBREM-63]

      Support for multihome servers requires an extension of the InvokerLocator syntax. For example,

      socket://multihome:6500/?homes=10.32.4.2!192.168.4.2


      will create a server bound to 10.32.4.2 and 192.168.4.2.

      The jboss-remoting.jar file is available at http://repository.jboss.com/jboss/remoting/

      The complete distribution zip file is available at http://www.jboss.org/jbossremoting/downloads/ .

      Feedback is welcome on the Remoting user forum: http://www.jboss.com/index.html?module=bb&op=viewforum&f=222.

        • 1. Re: Remoting 2.4.0.GA is now available
          KRISHNA P Newbie

          Hi,

          I have a couple of questions about the Remoting 2.4.0 GA version. Thanks for your response.

          1. Is it compatible with JBoss AS 4.2.2 GA?
          2. We currently use the Remoting 2.2.2 SP2 version. What are the files (only jboss-remoting.jar?) that need to be upgraded , and the application server folder (server\lib?) for these files?

          Thank much.

          • 2. Re: Remoting 2.4.0.GA is now available
            KRISHNA P Newbie

            Hi Ron or others,

            Can you please answer my question? Appreciate your help.

            Thanks

            • 3. Re: Remoting 2.4.0.GA is now available
              Ron Sigal Master

              Is Remoting 2.5 compatible with AS 4.2.x? Good question. It's not a combination that has been tested officially, although it's clear from the forum that people are using them together.

              Generally speaking, EJB2 and EJB3 are fairly independent of Remoting details, so I would guess that they would be compatible with Remoting 2.5. On the other hand, JBossMessaging is much more tied to Remoting details, so I would get a new JBM release. In particular, I would look for a version of JBM that ships with AS 5, which is an environment in which JBM uses Remoting 2.5 You would have to check with the JBM guys about their other dependencies.

              Good luck. If you go ahead and try Remoting 2.5 with AS 4.2.x, please let us know how it goes.

              -Ron

              • 4. Re: Remoting 2.4.0.GA is now available
                KRISHNA P Newbie

                Thanks much, Ron. I will let you know how the upgrade goes.

                Regards