2 Replies Latest reply on Jan 29, 2008 4:13 PM by JeanDenis Bertron

    Deployment failure : INIT_WAITING_DEPLOYER

    fredatwork Newbie

      Hello,

      I'm trying to have the Spring deployer working (I'm a newbee with it) and I keep having deployment failures with a dummy hello-world-kind-of spring file (INIT_WAITING_DEPLOYER):

      I've got a working JBoss AS (4.2.1).

      In the $JBOSS_HOME/server/default/deploy directory, I've created the required Spring deployer structure :

      jboss-spring-jdk5.deployer/
       jboss-spring-jdk5.jar
       META-INF/
       jboss-service.xml
      


      I copied all the Spring distribution jars in $JBOSS_HOME/server/default/deploy/jboss-spring-jdk5.deployer/ as well as in $JBOSS_HOME/server/default/lib/ .


      The jboss-service.xml file of the deployer is :
      <?xml version="1.0" encoding="UTF-8"?>
      
      <server>
      
       <!--
       The JBoss Spring Deployer
       -->
       <server>
       <mbean code="org.jboss.spring.deployment.SpringBeanFactoryDeployer" name="jboss.spring:service=SpringBeanFactoryDeployer" />
       </server>
      
      </server>
      


      I keep failing deploying a file named springapp.spring with the following content :
      springapp.spring/
       com/rubis/springapp/biz/Hello.class
       com/rubis/springapp/biz/HelloImpl.class
       meta-inf/
       jboss-spring.xml
      


      The jboss-spring.xml Spring configuration file is :
      <?xml version="1.0" encoding="UTF-8"?>
      <beans xmlns="http://www.springframework.org/schema/beans"
       xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
       xsi:schemaLocation="http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans-2.0.xsd">
      
       <bean id="hello" class="com.rubis.spring.biz.HelloImpl">
       <property name="greetings">
       <value>Good Morning!...</value>
       </property>
       </bean>
      
      </beans>
      


      Any idea what's wrong with this ?

      Fred