6 Replies Latest reply on Sep 3, 2005 7:43 PM by Joshua Tree

    Issues when trying to run Hello example in BPEL

    Alejandro Guizar Master

      Hi Ashwin,

      There are some problems with the JAXP implementation in JDK 1.5. Open the Ant build file in the 'hello' directory and add this entry in the path structure named 'wsdlgen.classpath':

      <pathelement location="${jbpm.bpel.home}/lib/xalan/xalan.jar" />

      There are similar entries there, so you'll locate the spot easily. If you run into more problems, please provide the version numbers of your JDK, JBoss and jBPM BPEL distributions to help us reproduce your environment.

        • 1. Re: Issues when trying to run Hello example in BPEL
          Alejandro Guizar Master

          Ashwin,

          I noticed you posted this in the SourceForge forum. Do not post there as any new entry will be deleted. I reproduce your question below.

          Hi ,
          I tried running the BPEL Hello example
          1. I deployed the bar-deployer.sar under jboss/server/default/deploy
          2. I also followed the steps in HelloWorldexample and everything went on fine until i tried deploying the hello-application.bar into jboss , When i try doing it , i get the following error:

          18:00:08,966 ERROR [MainDeployer] could not create deployment:
          file:/D:/jboss/jboss-4.0.2/server/default/deploy/hello-application.bar
          org.jboss.deployment.DeploymentException: problem creating module:
          hello-application.bar; - nested throwable: (java.lang.NullPointerException)
           at org.jboss.jbpm.bar.BARDeployer.create(BARDeployer.java:159)
           at org.jboss.deployment.MainDeployer.create(MainDeployer.java:918)
          ....

          Unfortunately, your stack trace is incomplete and I don't know your environment so I can't reproduce your problem. Please provide this information.

          • 2. Re: Issues when trying to run Hello example in BPEL
            Ronald van Kuijk Master

             

            "aguizar" wrote:
            Ashwin,

            I noticed you posted this in the SourceForge forum. Do not post there as any new entry will be deleted.


            • 3. Re: Issues when trying to run Hello example in BPEL
              Igor Brito Alves Newbie

              I'm having problems to deploy the Hello example. When I call ant deploy-hello-application appears on the jBoss server this:

              17:15:41,359 ERROR [URLDeploymentScanner] Incomplete Deployment listing:

              --- Packages waiting for a deployer ---
              org.jboss.deployment.DeploymentInfo@33d0c2bb { url=file:/F:/projeto_webflowah/testes/jboss-4.0.2/server/default/deploy/hello-application.bar }
              deployer: null
              status: null
              state: INIT_WAITING_DEPLOYER
              watch: file:/F:/projeto_webflowah/testes/jboss-4.0.2/server/default/deploy/hello-application.bar
              altDD: null
              lastDeployed: 1123877741343
              lastModified: 1123877741343
              mbeans:

              --- Incompletely deployed packages ---
              org.jboss.deployment.DeploymentInfo@33d0c2bb { url=file:/F:/projeto_webflowah/testes/jboss-4.0.2/server/default/deploy/hello-application.bar }
              deployer: null
              status: null
              state: INIT_WAITING_DEPLOYER
              watch: file:/F:/projeto_webflowah/testes/jboss-4.0.2/server/default/deploy/hello-application.bar
              altDD: null
              lastDeployed: 1123877741343
              lastModified: 1123877741343
              mbeans:


              Why jBoss didn't deploy the .BAR file?, does anybody knows?


              i'm using:

              - Windows XP Pro SP2
              - J2SE 5
              - jBoss 4.0.2
              - jBpm BPEL extension 1.0 alpha2
              - Tomcat 5 for WSDP
              - JWSDP 1.6



              thx my friends! :)


              • 4. Re: Issues when trying to run Hello example in BPEL
                Alejandro Guizar Master

                The BAR deployer service needs to be deployed to JBoss before it can deploy .BAR files. Please check section 2.4, "Server Setup", of the jBPM BPEL user guide (included in the distribution) for instructions on packaging and deploying bar-deployer.sar.

                • 5. Re: Issues when trying to run Hello example in BPEL
                  Igor Brito Alves Newbie

                  I got it! I reinstall jBoss and the jBpm BPEL extension and did all over again... I ran JUnit test and no erros or warnings!

                  thx!! :)

                  • 6. Re: Issues when trying to run Hello example in BPEL
                    Joshua Tree Newbie

                    Hi,

                    I was having a similiar problem and now it´s OK with
                    Aguizar tip.



                    deploy-definition:
                    [java] 00:42:27,580 DEBUG JbpmConfiguration : jbpm.task.instance.class=org.jbpm.taskmgmt.exe.TaskInstance
                    [java] 00:42:27,580 DEBUG JbpmConfiguration : jbpm.scheduler.service.factory=org.jbpm.scheduler.impl.SchedulerServiceImpl
                    [java] 00:42:27,590 DEBUG JbpmConfiguration : jbpm.deploy.jndi.context=bpelProcesses
                    [java] 00:42:30,725 DEBUG LocalEntityResolver : bpel_definition_1_0.xsd maps to URL: jar:file:/C:/Java/jbpm-bpel-1.0-alpha2/build/jbpm-bpel-1.0-alpha2.jar!/org/jbpm/bpel/xml/util/bpel_definition_1_0.xsd
                    [java] Compiler warnings:
                    [java] line 19: Attribute 'portType' outside of element.
                    [java] 00:42:31,827 DEBUG BpelReader : read wsdl document: hello.wsdl
                    [java] 00:42:31,827 DEBUG LocalEntityResolver : wsdl.xsd maps to URL: jar:file:/C:/Java/jbpm-bpel-1.0-alpha2/build/jbpm-bpel-1.0-alpha2.jar!/org/jbpm/bpel/xml/util/wsdl.xsd
                    [java] 00:42:31,927 DEBUG LocalEntityResolver : plink_1_1.xsd maps to URL: jar:file:/C:/Java/jbpm-bpel-1.0-alpha2/build/jbpm-bpel-1.0-alpha2.jar!/org/jbpm/bpel/xml/util/plink_1_1.xsd
                    [java] 00:42:32,117 ERROR JndiProcessDeployer : deployment failed
                    [java] java.lang.NullPointerException
                    [java] at org.jbpm.bpel.xml.ErrorListenerAdapter.error(ErrorListenerAdapter.java:22)
                    [java] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.postErrorToListener(TransformerImpl.java:694)
                    [java] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:646)
                    [java] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:279)
                    [java] at org.jbpm.bpel.xml.ImportWsdlLocator.getInputSource(ImportWsdlLocator.java:110)
                    [java] at org.jbpm.bpel.xml.ImportWsdlLocator.getBaseInputSource(ImportWsdlLocator.java:73)
                    [java] at com.ibm.wsdl.xml.WSDLReaderImpl.readWSDL(Unknown Source)
                    [java] at org.jbpm.bpel.xml.BpelReader.readWsdlDocument(BpelReader.java:304)
                    [java] at org.jbpm.bpel.par.ParDescriptorArchiveParser.readDocuments(ParDescriptorArchiveParser.java:68)
                    [java] at org.jbpm.bpel.par.ParDescriptorArchiveParser.readFromArchive(ParDescriptorArchiveParser.java:47)
                    [java] at org.jbpm.jpdl.par.ProcessArchive.parseProcessDefinition(ProcessArchive.java:46)
                    [java] at org.jbpm.bpel.par.JndiProcessDeployer.deployProcessArchive(JndiProcessDeployer.java:53)
                    [java] at org.jbpm.bpel.par.JndiProcessDeployer.deployProcessArchives(JndiProcessDeployer.java:184)
                    [java] at org.jbpm.bpel.par.JndiProcessDeployer.main(JndiProcessDeployer.java:160)
                    BUILD SUCCESSFUL
                    Total time: 6 seconds

                    Thanks