4 Replies Latest reply on Jun 20, 2008 12:26 PM by Burt Prior

    Big problem when switching to 3.2.1.GA from 3.1.5. (using my

    Milan Manojlovic Newbie

      Hi all,

      I have a following show stopping problem ...

      I have a project using frameworks:

      myfaces 1.2.3.
      faceslets 1.1.4
      richfaces ... 3.1.5. GA, or 3.2.1. GA

      When we used 3.1.5 GA everything worked fine, more or less,
      but when I tried switching to 3.2.1 GA (for some reason not relevant to this problem) all the links stopped working.
      I get a following Exception:

      javax.faces.application.ViewExpiredException: /foobar.jsfThe expected view was not returned for the view identifier: /foobar.jsf
      

      (managed bean methods don't get invoked)

      firebug reports a javascript error which it also reports when 3.1.5 GA is used, but it doesn't break the link
      [Exception... "Component is not available" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsSessionStore.js :: sss_saveState :: line 1753" data: no]
      file:///C:/Program%20Files/Mozilla%20Firefox/components/nsSessionStore.js
      Line 1753
      


      I made a small test application to demonstrate the behavior and I can send the WAR file if it helps solve the problem.
      I tried the test application with jsf RI and there were no problems, so I guess that this is only myfaces - richfaces issue.
      (I've configured web.xml with no filters, except the ajax4jsf filter, as suggested)

      Thanks in advance!
      Milan