1 Reply Latest reply on Oct 23, 2005 7:48 AM by Koen Aers

    org.jbpm.graph.def.DelegationException

    Frank Verbruggen Newbie

      Hi all,

      I have tried to deploy a process on my JBoss 403 programmatically and it works just fine.
      The process gets deployed and I can request it with the findAll method.
      The problem is that when I start to 'execute' my processdefinition with a processinstance it cant find the action class associated with my first transition.
      I have tried a lot, but can't seem to get it to work?

      My client gets a org.jbpm.graph.def.DelegationException
      But my server shows the following:
      ERROR [GraphElement] action threw exception: couldn't get value for file 'classes/nl/inkassounie/focus/action/ContextInitializerAction.class'

      any good advice?
      PS. my action class needs to be versioned with my process!

      Thx in advance,


      Frank Verbruggen
      Software Architect

        • 1. Re: org.jbpm.graph.def.DelegationException
          Koen Aers Master

          Frank,

          You should use the parfile deployment functionality to do that. You create a par file (essentially a zip file) with the processdefinition.xml file containing the process definition in the root and add your action classes to a 'classes' folder in this par file. Then use ant or the api to deploy this par file to the database.
          Alternatively, you can use the GPD that includes all classes mentioned in the processdefinition.xml file automatically during deployment.
          Have a look at the 'build.processes' tag in the 'build.xml' file of jbpm for an example of doing it 'the ant way'.

          Regards,
          Koen