1 Reply Latest reply on Dec 2, 2005 7:47 PM by Alejandro Guizar

    Why I cant deploy hello example in JbpmBpel (Help, please!!!

    Fabricio Nogueira Newbie

      Hello all,

      I'm studying jbpm Bpel to use it in some works, but neither the basic hello example I'm not being able to execute. I'll show you here what I did and what I'm getting.

      I installed jboss-4.0.3SP1 and than jBPM-BPEL 1.0 alpha 2;

      I followed all the userguide steps and I could execute all of them until generate schema in my postgres database with no problems.

      Now, to do the most important thing - see the stuff working in fact running hello example - I'm getting errors in:

      I run ant pack-definition and the .par file is generaited without problem, but
      when I need to run ant deploy-definition
      , I'm getting this after many messages:

      [deploypar] 21:06:36,060 DEBUG BpelReader : registered activity reader: name=validate, class=org.jbpm.bpel.xml.ValidateReader
      [deploypar] 21:06:36,288 DEBUG LocalEntityResolver : wsdl.xsd maps to URL: jar:file:/usr/local/jbpmbpel/build/jbpm-bpel-1.0-alpha3.jar!/org/jbpm/bpel/xml/util/wsdl.xsd
      [deploypar] 21:06:36,342 DEBUG LocalEntityResolver : plink_1_1.xsd maps to URL: jar:file:/usr/local/jbpmbpel/build/jbpm-bpel-1.0-alpha3.jar!/org/jbpm/bpel/xml/util/plink_1_1.xsd
      [deploypar] 21:06:36,605 ERROR ProblemCollector : META-INF/bpel-definition.xml Namespace for prefix 'plt' has not been declared.
      [deploypar] 21:06:36,614 ERROR ProblemCollector : META-INF/bpel-definition.xml unable to upgrade wsdl document: hello.wsdl
      [deploypar] javax.xml.transform.TransformerException: java.lang.RuntimeException: Namespace for prefix 'plt' has not been declared.
      ........................
      [deploypar] [Fatal Error] :-1:-1: Premature end of file.
      [deploypar] 21:06:36,752 DEBUG ProcessArchiveDeployer : starting transaction to deploy process BpelDefinition(b4b0a4)
      [deploypar] 21:06:36,871 DEBUG ProcessArchiveDeployer : flushing...
      [deploypar] 21:06:36,943 DEBUG ProcessArchiveDeployer : committing transaction to deploy process BpelDefinition(b4b0a4)

      BUILD SUCCESSFUL
      Total time: 17 seconds


      It's weird, because even with that error it show BUILD SUCCESSFUL, and according to the userguide the final messages must be:

      [deploypar] 18:13:45,030 INFO BpelReader : read bpel process: hello.bpel
      [deploypar] 18:13:45,260 DEBUG ProcessArchiveDeployer : starting transaction to deploy process BpelDefinition(helloWorld)
      [deploypar] 18:13:50,998 DEBUG ProcessArchiveDeployer : flushing...
      [deploypar] 18:13:51,389 DEBUG ProcessArchiveDeployer : committing transaction to deploy process BpelDefinition(helloWorld)

      All steps after this don't work too, due to that error.

      I saw another post in this following with a similar error:

      http://www.jboss.org/index.html?module=bb&op=viewtopic&p=3888657

      I used Aguizar tip changing my build.xml file adding

      line inside "wsdlgen.classpath". This element doesn't exist in my build.xml file. I added it in
      wsdlgen.classpath, deployer.classpath, test.classpath elements. And I run ant deploy-definition and the same error occurs.

      I really don't have any idea about what I could do to solve this problem. My only hope is here in this forum. Please, help me!!!!! I need to make it work and use Jbpm Bpel.