9 Replies Latest reply on Apr 25, 2006 3:27 PM by Brian Viveiros

    Internal Error Processing Dirty Regions with jBPM Graphical

    bechemeko Newbie

      I have just installed jBPM under Eclipse Version: 3.1.1 with the MyEclipseIDE plugin. When I try to open the gpd.xml file using the jBPM Graphical Process Designer XML editor, I immediately get an error (

      'Processing Dirty Regions','An internal error occurred during: "Processing Dirty Regions".'
      ). Clicking OK dismissed the error but it seems to reappear every time a change is made to the XML file.

      If I open the XML file using MyEclipse XML editor, everything works fine.

      How do I get rid of the error to be able to effectively use the GPD?

        • 1. Re: Internal Error Processing Dirty Regions with jBPM Graphi
          ishafizan ishak Newbie

          currently trying to evaluate jbpm with eclipse as the ide...already tried drools separately, verdict: thumbs up :) Having problems with the designer which I hope someone could drop in and give some insight

          env:
          - winXP pro 1gb ram notebook
          - eclipse3.1, myeclipse4.0
          - downloaded jbpm-3.0.2.zip, jbpm-bpel-1.0-alpha3.zip,jbpm-gpd-feature-3.0.5.zip,jbpm-gpd-site-3.0.5.zip

          steps taken:
          - create new jbpm project through wizard
          - create new process defn..click finish

          immediately got the same error'An Internal error occured during "Processing Dirty Regions"....the details button is locked. Yes, could continue drawing (on gpd.xml)...but it's annoying if it pops up for every single update.

          steps taken...
          - did a fresh installation of eclipse and repeated the designer installation steps
          result:
          -same darn thing happened

          does anyone have a solution?

          • 2. Re: Internal Error Processing Dirty Regions with jBPM Graphi
            Koen Aers Master

            The problems originates almost certainly from the MyEclipse installation. Is it possible to post the relevant fraction of the Eclipse .log file?

            Regards,
            Koen

            • 3. Re: Internal Error Processing Dirty Regions with jBPM Graphi
              Ronald van Kuijk Master

              additional info: the error disappears if you do not validate against an xsd. So removing it in the top of the processdefinition removes this error. One issue I had (do not know if it is still true for the current gpd) is that you loose positioning of the nodes and have to do a manual layout.

              • 4. Re: Internal Error Processing Dirty Regions with jBPM Graphi
                Koen Aers Master

                And is it a MyEclipse issue then Ronald?

                • 5. Re: Internal Error Processing Dirty Regions with jBPM Graphi
                  Ronald van Kuijk Master

                  I do not have the problem editing the xml page with the xsd enabled either in eclipse with just myeclipse or in eclipse with the gpd. So it's probably something like one biting the other, where I won't go into who's doing the biting.

                  :-)

                  • 6. Re: Internal Error Processing Dirty Regions with jBPM Graphi
                    ishafizan ishak Newbie

                    tx for the swift attention :)

                    here's the .log snippet: (let me know if u need anyhting else)
                    !ENTRY org.eclipse.core.runtime 4 2 2005-12-08 08:49:03.781
                    !MESSAGE An internal error occurred during: "Processing Dirty Regions".
                    !STACK 0
                    java.lang.NoSuchMethodError: org.apache.xerces.xni.XMLResourceIdentifier.getNamespace()Ljava/lang/String;
                    at org.eclipse.wst.xml.core.internal.validation.XMLValidator._internalResolveEntity(XMLValidator.java:348)
                    at org.eclipse.wst.xml.core.internal.validation.XMLValidator$MyEntityResolver.resolveEntity(XMLValidator.java:326)
                    at org.apache.xerces.impl.XMLEntityManager.resolveEntity(XMLEntityManager.java:545)
                    at org.apache.xerces.impl.xs.traversers.XSDHandler$LocationResolver.resolveEntity(XSDHandler.java:277)
                    at org.apache.xerces.impl.xs.traversers.XSDHandler.parseSchema(XSDHandler.java:359)
                    at org.apache.xerces.impl.xs.XMLSchemaValidator.parseSchemas(XMLSchemaValidator.java:2059)
                    at org.apache.xerces.impl.xs.XMLSchemaValidator.handleStartElement(XMLSchemaValidator.java:1620)
                    at org.apache.xerces.impl.xs.XMLSchemaValidator.startElement(XMLSchemaValidator.java:556)
                    at org.apache.xerces.impl.XMLNamespaceBinder.handleStartElement(XMLNamespaceBinder.java:832)
                    at org.apache.xerces.impl.XMLNamespaceBinder.startElement(XMLNamespaceBinder.java:568)
                    at org.apache.xerces.impl.dtd.XMLDTDValidator.startElement(XMLDTDValidator.java:809)
                    at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElement(XMLDocumentFragmentScannerImpl.java:752)
                    at org.apache.xerces.impl.XMLDocumentScannerImpl$ContentDispatcher.scanRootElementHook(XMLDocumentScannerImpl.java:950)
                    at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(XMLDocumentFragmentScannerImpl.java:1523)
                    at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:333)
                    at org.apache.xerces.parsers.StandardParserConfiguration.parse(StandardParserConfiguration.java:525)
                    at org.apache.xerces.parsers.StandardParserConfiguration.parse(StandardParserConfiguration.java:581)
                    at org.apache.xerces.parsers.XMLParser.parse(XMLParser.java:147)
                    at org.apache.xerces.parsers.AbstractSAXParser.parse(AbstractSAXParser.java:1158)
                    at org.eclipse.wst.xml.core.internal.validation.XMLValidator.validate(XMLValidator.java:216)
                    at org.eclipse.wst.xml.ui.internal.validation.XMLValidator.validate(XMLValidator.java:71)
                    at org.eclipse.wst.xml.ui.internal.validation.ValidateAction$1.run(ValidateAction.java:97)
                    at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1719)
                    at org.eclipse.core.internal.resources.Workspace.run(Workspace.java:1739)
                    at org.eclipse.wst.xml.ui.internal.validation.ValidateAction.validate(ValidateAction.java:123)
                    at org.eclipse.wst.xml.ui.internal.validation.core.ValidateAction.run(ValidateAction.java:206)
                    at org.eclipse.wst.xml.ui.internal.validation.Validator.validate(Validator.java:70)
                    at org.eclipse.wst.xml.ui.internal.validation.Validator.validate(Validator.java:92)
                    at org.eclipse.wst.xml.ui.internal.validation.DelegatingSourceValidator.validate(DelegatingSourceValidator.java:189)
                    at org.eclipse.wst.sse.ui.internal.reconcile.validator.ReconcileStepForValidator.validate(ReconcileStepForValidator.java:221)
                    at org.eclipse.wst.sse.ui.internal.reconcile.validator.ReconcileStepForValidator.reconcileModel(ReconcileStepForValidator.java:188)
                    at org.eclipse.jface.text.reconciler.AbstractReconcileStep.reconcile(AbstractReconcileStep.java:96)
                    at org.eclipse.wst.sse.ui.internal.reconcile.validator.ValidatorStrategy.reconcile(ValidatorStrategy.java:176)
                    at org.eclipse.wst.sse.ui.internal.reconcile.StructuredRegionProcessor.process(StructuredRegionProcessor.java:137)
                    at org.eclipse.wst.sse.ui.internal.reconcile.DirtyRegionProcessor.run(DirtyRegionProcessor.java:412)
                    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:76)

                    i'll see what i can do with kukeltje's solution and give and update

                    • 7. Re: Internal Error Processing Dirty Regions with jBPM Graphi
                      ishafizan ishak Newbie

                      Hi, update and questions.

                      'So removing it in the top of the processdefinition removes this error'
                      How do i do this? can u guide me which section do i need to remove pls?

                      i tried:
                      - remove the http to xsd section
                      - totally removed xsi:schemaLocation

                      both had the same effect: the jbpm gpd cannot be used anymore, even if i right click gpd.xml->open with->gpd.

                      here's the generic processdefinition.xml:

                      <?xml version="1.0" encoding="UTF-8"?>
                      
                      <process-definition
                       xmlns="http://jbpm.org/3/jpdl" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                       xsi:schemaLocation="http://jbpm.org/3/jpdl http://jbpm.org/xsd/jpdl-3.0.xsd"
                       name="ThisIsATest">
                      </process-definition>
                      


                      tx for spending time on this, i'll continue evaluating jbpm but would love if the designer is available for usage. Need to start the tutorials somehow :) It'll be a plus point. fyi, we do have licenses of RSA....was wondering if u guys can share any experiences that u may have on designing the process models in RSA, auto create the necessary files and then deploy in jbpm, currently we are using jboss as the development platform. not entirely sure how this could work, RSA->jbpm->jboss. appreciate any insights/ideas that u may have:)

                      • 8. Re: Internal Error Processing Dirty Regions with jBPM Graphi
                        ishafizan ishak Newbie

                        btw, i'll be looking into the bpel/workflow capabilities of jbpm and see how it fits to current soa architecture and process models...was excited with the news of drools being incorporated into jbpm. currently we have tried oracle bpel engine with some good result, but we are keeping our options open before committing. had a quick glance at the end xml codes and have a gut feeling jbpm can fulfill the needs. just need to test it out now :)

                        • 9. Re: Internal Error Processing Dirty Regions with jBPM Graphi
                          Brian Viveiros Newbie

                          It looks like MyEclipse (including the latest version 4.1.1) ships with an old version of Apache xerces. I fixed the problem by copying the file as described below.

                          Copy the file %ECLIPSE_HOME%\plugins\org.apache.xerces_2.7.0\xercesImpl.jar
                          to C:\Program Files\MyEclipse\eclipse\plugins\org.apache.xerces_4.0.13

                          The version numbers make it look backwards but MyEclipse ships with XML4J 4.0.13 which contains an older version of the xercesImpl.jar file.

                          Hope this helps.