2 Replies Latest reply on Feb 14, 2006 2:41 PM by Wayne Williams

    jBPM BPEL Scheduler

    Roy Forever Newbie

      Excuse me,

      I have a process with a pick which contain an onMessage and an onAlarm

      <bpws:pick>
       <bpws:onMessage operation="performNext" partnerLink="client"
       portType="my:BankLoanRequestPortType" variable="next">
       <bpws:correlations>
       <bpws:correlation set="csSessionId"/>
       </bpws:correlations>
      
       <bpws:empty/>
       </bpws:onMessage>
       <bpws:onAlarm for="'PT55M'">
       <bpws:empty/>
       </bpws:onAlarm>
      </bpws:pick>
      


      The process is possible to deploy and execute.
      Therefore, when it reach the onAlarm, an exception was thrown
      Below is last part of the exception
      Caused by: java.lang.RuntimeException: unable to schedule alarm
       at org.jbpm.bpel.scheduler.exe.AlarmInstance.start(AlarmInstance.java:55)
       at org.jbpm.bpel.def.Pick.execute(Pick.java:50)
       at org.jbpm.bpel.def.StructuredActivity$StructureStart.leave(StructuredActivity.java:246)
       at org.jbpm.graph.def.Node.execute(Node.java:305)
       at org.jbpm.bpel.def.Activity.enter(Activity.java:84)
       ... 88 more
      Caused by: javax.naming.NameNotFoundException: Scheduler not bound
       at org.jnp.server.NamingServer.getBinding(NamingServer.java:491)
       at org.jnp.server.NamingServer.getBinding(NamingServer.java:499)
       at org.jnp.server.NamingServer.getObject(NamingServer.java:505)
       at org.jnp.server.NamingServer.lookup(NamingServer.java:278)
       at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:610)
       at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:572)
       at javax.naming.InitialContext.lookup(InitialContext.java:351)
       at org.jbpm.bpel.scheduler.exe.AlarmInstance.start(AlarmInstance.java:48)
       ... 92 more
      


      Is that my configure will cause the Scheduler not bind?
      My setting is already posted before
      http://www.jboss.com/index.html?module=bb&op=viewtopic&t=74798
      Notice that I am using the MySQL one.

      What should I do for solving the problem?

      Thank you very much ^^
      Roy