1 Reply Latest reply on Jul 3, 2006 8:06 PM by Brad O'Hearne

    Database script creation not working

    Brad O'Hearne Newbie

      I am trying to run the database creation script target to create Oracle database scripts for jBPM, in the jbpm-db of the jbpm starters kit distribution, specifically using:

      ant oracle.scripts

      The execution of this target says that it succeeds, with the following output:

      ----------
      $ ant oracle.scripts
      Buildfile: build.xml

      oracle.scripts:

      prepare:

      compile.jbpm:

      compile.jbpm.test:

      compile.identity:

      compile.webapp:

      compile.identity.test:

      compile.examples:

      compile:

      db.scripts:
      [mkdir] Created dir: C:\jbpm-starters-kit-3.0.3\jbpm-db\build\oracle\scripts

      [java] syntax: JbpmSchema create
      [java] syntax: JbpmSchema drop
      [java] syntax: JbpmSchema clean
      [java] syntax: JbpmSchema scripts

      BUILD SUCCESSFUL
      Total time: 1 second
      ----------

      However, my build/oracle/scripts directory is completely empty after running this. My hibernate.properties file is as follows:

      ----------
      hibernate.dialect=org.hibernate.dialect.Oracle9Dialect
      # for Oracle 8 compatibility use
      #hibernate.dialect=org.hibernate.dialect.OracleDialect

      hibernate.connection.driver_class=oracle.jdbc.driver.OracleDriver
      #hibernate.connection.url=jdbc:oracle:thin:@::
      #hibernate.connection.username=
      #hibernate.connection.password=
      hibernate.connection.url=jdbc:oracle:thin:@localhost:1521:XE
      hibernate.connection.username=SYSTEM
      hibernate.connection.password=mypassword

      hibernate.show_sql=true
      hibernate.c3p0.min_size=1
      hibernate.c3p0.max_size=3

      hibernate.query.substitutions=true 1, false 0
      ----------

      My build.properties files is as follows:

      ----------
      jbpm.3.location=../jbpm

      #upgrade.hibernate.properties=hsqldb/hibernate.properties
      upgrade.hibernate.properties=oracle/hibernate.properties
      #upgrade.libdir=hsqldb/lib
      upgrade.libdir=oracle/lib
      #upgrade.old.schema.script=hsqldb/upgrade.scripts/hsqldb.create.jbpm.3.0.2.sql
      ----------

      My database is up and running, I can connect to it, and I don't see any errors anywhere -- but I don't get any scripts generated! Help!

      Thanks,

      Brad