10 Replies Latest reply on Aug 8, 2006 6:15 AM by mailinator

    Deployment Problems

    Steven McDermott Newbie

      Hi Again,

      Sorry of this is yet another simple question but I am new to the jBPM and am learning as I go.

      I have created a new process, added tasks and swimlanes and am ready to deploy. Whenever I go to the deployment tab I tick all the necessary folders as mentioned in the documents but when I click on "Deploy Process Archive..." I get an "Unexpected Deployment Exception". Clicking on Details just tells me to look in the logs.

      Where are these logs? The only one I can seem to find is the boot log.

      Also when I click on test connection it is successful.

      Any ideas?

        • 1. Re: Deployment Problems
          Ronald van Kuijk Master

          the logs referred to are the eclipse logs in workspace/.metadata but also have a look at the appserver logs

          • 2. Re: Deployment Problems
            Steven McDermott Newbie

            Thanks for the quick reply. The log in .metadata shows this:

            !ENTRY org.jbpm.gd.jpdl.ui 4 0 2006-08-07 12:02:26.716
            !MESSAGE Exception happened while deploying
            !STACK 0
            java.io.IOException: Server returned HTTP response code: 500 for URL: http://localhost:8080/jbpm/upload
            at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
            at org.jbpm.ui.util.ProcessDeployer.deployProcessWithServlet(Unknown Source)
            at org.jbpm.ui.util.ProcessDeployer.access$3(Unknown Source)
            at org.jbpm.ui.util.ProcessDeployer$1.run(Unknown Source)
            at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:369)
            at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:313)
            at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:479)
            at org.jbpm.ui.util.ProcessDeployer.showProgressMonitorDialog(Unknown Source)
            at org.jbpm.ui.util.ProcessDeployer.deploy(Unknown Source)
            at org.jbpm.ui.editor.form.deployment.DeploymentForm$1.widgetSelected(Unknown Source)
            at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:90)
            at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
            at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:928)
            at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3348)
            at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2968)
            at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1914)
            at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1878)
            at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:419)
            at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
            at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:95)
            at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
            at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
            at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
            at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
            at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
            at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
            at java.lang.reflect.Method.invoke(Unknown Source)
            at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
            at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
            at org.eclipse.core.launcher.Main.run(Main.java:977)
            at org.eclipse.core.launcher.Main.main(Main.java:952)

            Can someone point out the problem for me?

            • 3. Re: Deployment Problems
              Ronald van Kuijk Master

              Yes, look at the server log, there should be a reason there for sending an http 500

              • 4. Re: Deployment Problems
                Steven McDermott Newbie

                Where can i find the server log? The only once I can find is the boot log.

                • 5. Re: Deployment Problems
                  Ronald van Kuijk Master

                  assuming you are using jboss, then it is probably turned of in the log4j config and only logs to the console (if you use one for starting jboss).

                  • 6. other guy, same problem
                    mailinator Novice

                    Hello,

                    I came as far as stevenm. Found the log4j.properties file, too (in your eclipse project in /bin/com) and since it says in line 1+2

                    # Set root logger level to DEBUG and its only appender to CONSOLE
                    log4j.rootLogger=DEBUG, CONSOLE

                    I guess no log file is created. So, how do I change line 2 so a log file is created?

                    Greetings

                    Florian



                    • 7. Re: Deployment Problems
                      Ronald van Kuijk Master

                      log4j for your SERVER, not eclipse or anything. in jboss it is in the /server//conf dir

                      • 8. Re: Deployment Problems
                        mailinator Novice

                        Thanks. Found a file named log4j.xml (that the right one?), but it was at /server/jbpm/conf
                        I tried to change the value of the "Target" parameter in the appender definition, first to "jbpmLog.txt" then with a full path, but in both cases I wasn't able to find the file. And console still displays messages (getting an exception quite at the beginning, sth. about main deployer having a problem...)

                        Some more tips?

                        - Florian

                        • 9. Re: Deployment Problems
                          Ronald van Kuijk Master

                          I myself have had some problems with the logging in the starterkit jbossAS. Can you copy one from a normal JBoss AS installation and try that one?

                          • 10. Re: Deployment Problems
                            mailinator Novice

                            Didn't work. But I did a new install of the starterkit plus the jboss eclipse IDE on another computer and now it works...

                            -Florian