10 Replies Latest reply on Sep 7, 2006 10:53 AM by Marouene GUESMI

    jbpm.war with jboss-4.0.4.GA - How to... Pleae help ???

    Raoul Batista Newbie

      Hi All,

      We want to use JBoss to propose it as a BPM solution to our customers. We haven't decided yet how we will use it, as it is deployed in the starter kit or in a Servlet container, EJB... etc... It is said it is flexible and can be used in any "Java program"... First of all I need to understand how things work and I beleive working with jbpm.war will help a lot for that....
      When I deploy the jbpm.sar with jboss-4.0.4.GA, it seems there are no problem with that: No error in the log file and the service appears in the jmx-console...
      But when I deploy the jbpm.war I got the following error:

      2006-08-29 11:31:41,817 ERROR [STDERR] Exception in thread "JbpmScheduler"
      2006-08-29 11:31:41,817 ERROR [STDERR] java.lang.IllegalAccessError: tried to access method net.sf.ehcache.CacheManager.()V from class org.hibernate.cache.EhCacheProvider
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.hibernate.cache.EhCacheProvider.start(EhCacheProvider.java:124)
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.hibernate.impl.SessionFactoryImpl.(SessionFactoryImpl.java:180)
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1213)
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.jbpm.persistence.db.DbPersistenceServiceFactory.getSessionFactory(DbPersistenceServiceFactory.java:90)
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.jbpm.persistence.db.DbPersistenceService.getSessionFactory(DbPersistenceService.java:74)
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.jbpm.persistence.db.DbPersistenceService.getSession(DbPersistenceService.java:78)
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.jbpm.persistence.db.DbPersistenceService.getSchedulerSession(DbPersistenceService.java:244)
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.jbpm.JbpmContext.getSchedulerSession(JbpmContext.java:529)
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.jbpm.scheduler.impl.SchedulerThread.executeTimers(SchedulerThread.java:103)
      2006-08-29 11:31:41,817 ERROR [STDERR] at org.jbpm.scheduler.impl.SchedulerThread.run(SchedulerThread.java:70)

      I tried to find this error in the forum with the a search but no luck.... If someone has managed to install the jbpm.war, please tell me what I am missing. (According to what I understand, the GDP use the uploadServlet of the jbpm.war to deploy the process definition.)
      Am still confused about the architecture and how all components are working together. For example, jbpm is package as a java library and I wonder what is the advantage to have jbpm as JMX service. How does this work ? Is the jbpm.war using the jbpm as a library... ? Or has it something to do with jbpm as a JMX service..... ? Sorry for all these questions but I can't find documentation explaining how all the components are working together (probably because I am new to Jboss...).

      Anyway thank you for your help,

      Arnaud.

        • 4. Re: jbpm.war with jboss-4.0.4.GA - How to... Pleae help ???
          Raoul Batista Newbie

          I replaced ehcache with a newer version and it solved my "IllegalAccessError..." problem.

          Thanks a lot!!!

          • 5. Re: jbpm.war with jboss-4.0.4.GA - How to... Pleae help ???
            njipwo Bertrand Newbie

            Hello kukeltje, hi ALClientView,

            i can't follow you technicaly when you mean

            replace ehcache with a newer version
            .

            Untill know i didn't have to work with the ehcache and always use the default one.

            Please can you give me moreexplaination how to switch to a new ehcache version.

            For back ground i was using bpel-1.0-alpha4 and jboss-4.0.3.SP1 and every think works well. For the logging feature i need to switch to jbpm-bpel-1.1-beta1. In the tutorial they advice to switch to 4.0.4-AG

            Thanks in advance for your contribution.

            Bertrand

            • 6. Re: jbpm.war with jboss-4.0.4.GA - How to... Pleae help ???
              Alejandro Guizar Master

               

              Please can you give me moreexplaination how to switch to a new ehcache version.

              JBoss AS does not include ehcache. However, jBPM uses it as its default cache provider. For this reason, the jBPM-jPDL service archive contains that library, and so does the jBPM-BPEL .sar.

              If you are switching to 1.1.Beta1, you need not worry about it because the buildfile contains separate targets for each AS version:
              build.service.403 bundles ehcache 1.1
              build.service.404 bundles ehcache 1.2

              • 7. Re: jbpm.war with jboss-4.0.4.GA - How to... Pleae help ???
                njipwo Bertrand Newbie

                Hello @all, hello alex,

                tanks for your kick answer and statement.

                I'm running know jbpm-bpel-1.1-beta1 with jboss-4.0.4-AG and i'm facing the same problem AlClientView described hier when triying to deploy a process definition (hello.par) to JBoss. He get it worked and i'll need help to fix this error.

                Thanks once again.


                Bertrand Njipwo

                • 8. Re: jbpm.war with jboss-4.0.4.GA - How to... Pleae help ???
                  njipwo Bertrand Newbie

                  Sorry hier the error trace from JBoss.

                  09:40:53,307 INFO [NamingHelper] JNDI InitialContext properties:{}
                  09:40:53,337 INFO [DatasourceConnectionProvider] Using datasource: java:/jbpmBpelDS
                  09:40:53,457 INFO [SettingsFactory] RDBMS: MySQL, version: 4.1.9-nt
                  09:40:53,467 INFO [SettingsFactory] JDBC driver: MySQL-AB JDBC Driver, version: mysql-connector-java-3.1.12 ( $Date: 2005-11-17 15:53:48 +0100 (Thu, 17 Nov 2005) $, $Revision$ )
                  09:40:53,577 INFO [Dialect] Using dialect: org.hibernate.dialect.MySQLInnoDBDialect
                  09:40:53,637 INFO [TransactionFactoryFactory] Using default transaction strategy (direct JDBC transactions)
                  09:40:53,677 INFO [TransactionManagerLookupFactory] No TransactionManagerLookup configured (in JTA environment, use of read-write or transactional second-level cache is not recommended)
                  09:40:53,698 INFO [SettingsFactory] Automatic flush during beforeCompletion():disabled
                  09:40:53,718 INFO [SettingsFactory] Automatic session close at end of transaction: disabled
                  09:40:53,738 INFO [SettingsFactory] JDBC batch size: 15
                  09:40:53,748 INFO [SettingsFactory] JDBC batch updates for versioned data: disabled
                  09:40:53,798 INFO [SettingsFactory] Scrollable result sets: enabled
                  09:40:53,808 INFO [SettingsFactory] JDBC3 getGeneratedKeys(): enabled
                  09:40:53,818 INFO [SettingsFactory] Connection release mode: auto
                  09:40:53,828 INFO [SettingsFactory] Maximum outer join fetch depth: 2
                  09:40:53,838 INFO [SettingsFactory] Default batch fetch size: 1
                  09:40:53,848 INFO [SettingsFactory] Generate SQL with comments: disabled
                  09:40:53,858 INFO [SettingsFactory] Order SQL updates by primary key: disabled
                  09:40:53,868 INFO [SettingsFactory] Query translator: org.hibernate.hql.ast.ASTQueryTranslatorFactory
                  09:40:53,908 INFO [ASTQueryTranslatorFactory] Using ASTQueryTranslatorFactory
                  09:40:53,908 INFO [SettingsFactory] Query language substitutions: {}
                  09:40:53,968 INFO [SettingsFactory] Second-level cache: enabled
                  09:40:53,978 INFO [SettingsFactory] Query cache: disabled
                  09:40:53,988 INFO [SettingsFactory] Cache provider: org.hibernate.cache.EhCacheProvider
                  09:40:54,028 INFO [SettingsFactory] Optimize cache for minimal puts: disabled
                  09:40:54,038 INFO [SettingsFactory] Structured second-level cache entries: disabled
                  09:40:54,118 INFO [SettingsFactory] Statistics: disabled
                  09:40:54,128 INFO [SettingsFactory] Deleted entity synthetic identifier rollback: disabled
                  09:40:54,148 INFO [SettingsFactory] Default entity-mode: pojo
                  09:40:54,449 INFO [SessionFactoryImpl] building session factory
                  09:40:54,479 ERROR [[DeployServlet]] Servlet.service() for servlet DeployServlet threw exception
                  java.lang.IllegalAccessError: tried to access method net.sf.ehcache.CacheManager.<init>()V from class org.hibernate.cache.EhCacheProvider
                  at org.hibernate.cache.EhCacheProvider.start(EhCacheProvider.java:124)
                  at org.hibernate.impl.SessionFactoryImpl.<init>(SessionFactoryImpl.java:180)
                  at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1213)
                  at org.jbpm.persistence.db.DbPersistenceServiceFactory.getSessionFactory(DbPersistenceServiceFactory.java:90)
                  at org.jbpm.persistence.db.DbPersistenceService.getSessionFactory(DbPersistenceService.java:74)
                  at org.jbpm.persistence.db.DbPersistenceService.getSession(DbPersistenceService.java:79)
                  at org.jbpm.persistence.db.DbPersistenceService.getGraphSession(DbPersistenceService.java:216)
                  at org.jbpm.JbpmContext.getGraphSession(JbpmContext.java:433)
                  at org.jbpm.JbpmContext.deployProcessDefinition(JbpmContext.java:172)
                  at org.jbpm.bpel.web.deploy.DeployServlet.doGet(DeployServlet.java:55)
                  at javax.servlet.http.HttpServlet.service(HttpServlet.java:697)
                  at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
                  at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
                  at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
                  at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
                  at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
                  at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
                  at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
                  at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
                  at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:175)
                  at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:74)
                  at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
                  at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
                  at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
                  at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
                  at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
                  at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
                  at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
                  at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
                  at java.lang.Thread.run(Thread.java:595)


                  • 9. Re: jbpm.war with jboss-4.0.4.GA - How to... Pleae help ???
                    njipwo Bertrand Newbie

                    Hi,

                    Hey i got it :)- My LoanProcess works know with Jboss 4.0.3.SP1 and jbpm.bpel-1.1.alpha.1. And i can use the logging feature.

                    I was already familiar with jbpm.bpel.1.0-alpha.4 so that why it toke me i little time to adapt the bpel process structure to the one use in alpha-1 (JMS, partnerLink :)-.


                    I just wan to relate that i couldn't find a solution for the issue related in this thread. The problem disappear alone after stopping and restarting my Jboss AS without changing any think in my settings. I got that problem yesterday and thougth about the advice in the jbpm.bpel-1.1.alpha.1 tutorial (switch to use Jboss 4.0.4.).




                    Bertrand Njipwo



                    • 10. Re: jbpm.war with jboss-4.0.4.GA - How to... Pleae help ???
                      Marouene GUESMI Newbie

                      HI GAYS!

                      Please I'm new to Jboss and JBPM, and JBPM-BPEL, I tried to follow the user guide of jbpm-bpel but still unable to deploy jbpm-bpel.sar.
                      I need your help gays! thanks :-)