2 Replies Latest reply on Sep 5, 2006 3:43 PM by Earnest Dyke

    NullPointerException in Eclipse Graph

    Earnest Dyke Novice

      Greetings all.

      I have searched the forum and I can find no problem similar to mine.

      I am in Eclipse, I have added a

      node-leave
      event with an action. If I right click on the action in the outline and click properties then click Handler,I can add the java class just fine but no matter what combinations I enter for Configuration Type and Field Value I get this:

      java.lang.NullPointerException
      at org.jbpm.ui.properties.ActionHandlerPropertyPage.performOk(Unknown Source)
      at org.eclipse.jface.preference.PreferenceDialog$11.run(PreferenceDialog.java:862)
      at org.eclipse.core.internal.runtime.InternalPlatform.run(InternalPlatform.java:1044)
      at org.eclipse.core.runtime.Platform.run(Platform.java:783)
      at org.eclipse.ui.internal.JFaceUtil$1.run(JFaceUtil.java:44)
      at org.eclipse.jface.util.SafeRunnable.run(SafeRunnable.java:148)
      at org.eclipse.jface.preference.PreferenceDialog.okPressed(PreferenceDialog.java:842)
      at org.eclipse.ui.internal.dialogs.FilteredPreferenceDialog.okPressed(FilteredPreferenceDialog.java:296)
      at org.eclipse.jface.preference.PreferenceDialog.buttonPressed(PreferenceDialog.java:227)
      at org.eclipse.jface.dialogs.Dialog$2.widgetSelected(Dialog.java:556)
      at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:90)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3125)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2758)
      at org.eclipse.jface.window.Window.runEventLoop(Window.java:809)
      at org.eclipse.jface.window.Window.open(Window.java:787)
      at org.eclipse.ui.dialogs.PropertyDialogAction.run(PropertyDialogAction.java:157)
      at org.jbpm.ui.action.PropertyDialogActionDelegate.run(Unknown Source)
      at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:246)
      at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:538)
      at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:488)
      at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:400)
      at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
      at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
      at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3125)
      at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2758)
      at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1699)
      at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
      at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:367)
      at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
      at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:103)
      at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
      at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
      at java.lang.reflect.Method.invoke(Unknown Source)
      at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
      at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
      at org.eclipse.core.launcher.Main.run(Main.java:973)
      at org.eclipse.core.launcher.Main.main(Main.java:948)


      I am using jBPM 3.0.8 and this is a snippet of my processdefinition.xml:

      <process-definition
       xmlns="" name="EmployerRegistration">
       <start-state name="start">
       <transition name="toWaitingToValidateMember" to="WaitingToValidateMember"></transition>
       </start-state>
       <state name="WaitingToValidateMember">
       <event type="node-leave">
       <action name="ValidateMember" class="com.vrs.selfserv.workflowaction.ValidateMember">
       <ssn>000000000</ssn>
       <lastName>test</lastName>
       <dob>01/01/1960</dob>
       <employerCode>99999</employerCode>
       </action>
       </event>
       </state>
      


      Anyone run into this before?

      Earnie!