6 Replies Latest reply on Sep 26, 2006 5:08 AM by Alejandro Guizar

    BPEL beta2 - com.sun.tools.javac.Main - Java 1.5.0_07

    Claus Wittmann Newbie

      For anyone who will get the same error while starting wscompile in BPEL beta 2 - here is the error and following up the sollution:

      ERROR if you use Java 1.5.0_07

      Buildfile: C:\EWorkspace\bpel-beta2\jbpm.bpel\doc\examples\atm\build.xml
      wscompile:
      [wscompile] command line: wscompile C:\Programme\Java\jre1.5.0_07\bin\java.exe -Duser.dir=C:\EWorkspace\bpel-beta2\jbpm.bpel\doc\examples\atm -classpath C:\entwicklung\sun\jwsdp-1.6\jaxrpc\lib\jaxrpc-api.jar;C:\entwicklung\sun\jwsdp-1.6\jaxrpc\lib\jaxrpc-impl.jar;C:\entwicklung\sun\jwsdp-1.6\jaxrpc\lib\jaxrpc-spi.jar;C:\EWorkspace\bpel-beta2\jbpm.bpel\doc\examples\atm\src\main\resources com.sun.xml.rpc.tools.wscompile.Main -d C:\EWorkspace\bpel-beta2\jbpm.bpel\doc\examples\atm\output\classes -features:norpcstructures,wsi,strict -import -keep -mapping C:\EWorkspace\bpel-beta2\jbpm.bpel\doc\examples\atm\output\resources\WEB-INF\jaxrpc-mapping.xml -s C:\EWorkspace\bpel-beta2\jbpm.bpel\doc\examples\atm\output\java -verbose C:\EWorkspace\bpel-beta2\jbpm.bpel\doc\examples\atm\src\main\resources\wscompile.xml
      [wscompile] [ServiceInterfaceGenerator: creating service interface: org.jbpm.bpel.tutorial.atm.AtmFrontEndService]
      [wscompile] [CustomExceptionGenerator: generating CustomException for: org.jbpm.bpel.tutorial.atm.UnauthorizedAccess]
      [wscompile] [CustomExceptionGenerator: generating CustomException for: org.jbpm.bpel.tutorial.atm.InsufficientFunds]
      [wscompile] Fehler: com.sun.tools.javac.Main ist im Klassenpfad nicht verfügbar..
      [wscompile] Fehler: Kompilierung fehlgeschlagen, die Fehler wurden gemeldet
      
      BUILD FAILED
      C:\EWorkspace\bpel-beta2\jbpm.bpel\doc\examples\common\webservice.build.xml:116: wscompile failed
      
      Total time: 5 seconds
      

      (ERROR: com.sun.tools.javac.Main is not available in your classpath)

      SOLLUTION
      start Eclipse
      go to Window \ Preferences \ Java \ Installed JREs
      Change either to Java 1.5.0_06 or do the following:
      select Java 1.5.0_07 - edit
      select "add external jars"
      go to your java_home directory \ lib and select tools.jar
      Open \ OK \ Ok
      Thats it.


      Greetings

      Claus