3 Replies Latest reply on Feb 17, 2007 7:18 PM by Alejandro Guizar

    JbpmBpelDS not bound

    Fiore Paolo Newbie

      Hi everyone,

      I installed JBOSS AS 4.0.4 GA succefull configured with hypersonic using jems-installer-1.2.0.BETA2.jar.

      After this i tried install JBPMBPEL.
      I dowloaded jbpm-bpel-1.1.Beta3.zip and unrar it.
      I configured build.properties in config folder.
      I run command 'ant build.sar' and ant 'deploy.sar'.

      When JBOSS AS start (the sar file was deployed in default profile) the following error appear:

      2007-02-16 14:58:20,890 FATAL [org.hibernate.connection.DatasourceConnectionProvider] Could not find datasource: java:/JbpmBpelDS
      javax.naming.NameNotFoundException: JbpmBpelDS not bound
      at org.jnp.server.NamingServer.getBinding(NamingServer.java:529)
      at org.jnp.server.NamingServer.getBinding(NamingServer.java:537)
      at org.jnp.server.NamingServer.getObject(NamingServer.java:543)
      at org.jnp.server.NamingServer.lookup(NamingServer.java:296)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:625)
      at org.jnp.interfaces.NamingContext.lookup(NamingContext.java:587)
      at javax.naming.InitialContext.lookup(InitialContext.java:347)
      at org.hibernate.connection.DatasourceConnectionProvider.configure(DatasourceConnectionProvider.java:52)
      at org.hibernate.connection.ConnectionProviderFactory.newConnectionProvider(ConnectionProviderFactory.java:124)
      at org.hibernate.connection.ConnectionProviderFactory.newConnectionProvider(ConnectionProviderFactory.java:56)
      at org.hibernate.cfg.SettingsFactory.createConnectionProvider(SettingsFactory.java:385)
      at org.hibernate.cfg.SettingsFactory.buildSettings(SettingsFactory.java:61)
      at org.hibernate.cfg.Configuration.buildSettings(Configuration.java:1928)
      at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1211)
      at org.jbpm.persistence.db.DbPersistenceServiceFactory.getSessionFactory(DbPersistenceServiceFactory.java:91)
      at org.jbpm.persistence.db.DbPersistenceService.getSessionFactory(DbPersistenceService.java:94)
      at org.jbpm.persistence.db.DbPersistenceService.getSession(DbPersistenceService.java:98)
      at org.jbpm.persistence.db.DbPersistenceService.getJobSession(DbPersistenceService.java:281)
      at org.jbpm.JbpmContext.getJobSession(JbpmContext.java:526)
      at org.jbpm.job.executor.JobExecutorThread.acquireJobs(JobExecutorThread.java:109)
      at org.jbpm.job.executor.JobExecutorThread.run(JobExecutorThread.java:56)


      Does some configuration file is wrong configured?

        • 1. Re: JbpmBpelDS not bound
          Jason Greiner Newbie

          Inside the SAR is a jbpm-bpel.war file. The war attempts to deploy before the DS. Once the sar starts the everything works out fine. However if you do not want to see that error pull the war out of the sar and deploy it separately.

          • 2. Re: JbpmBpelDS not bound
            Ronald van Kuijk Master

            or.... the DS is not deployed?

            • 3. Re: JbpmBpelDS not bound
              Alejandro Guizar Master

              Unless jbpm-bpel-ds.xml is removed from jbpm-bpel.sar, the data source gets deployed along the jbpm bpel service.

              However, the web application jbpm-bpel.war also gets deployed before the service and, sometimes, even before the data source.

              The web app starts the jBPM job executor thread (see the bottom of the stack trace). If the web app is the first to start, The job executor will access the data source before the data source is ready. Note that this is harmless: as you can read from the server log, the thread goes to sleep for a while and then retries:

              2007-02-09 14:50:07,590 ERROR [org.jbpm.job.executor.JobExecutorThread] exception in job executor thread. waiting 30000 milliseconds

              By the time the thread wakes up, the data source is available already. As jgreiner says, deploying the web app separately prevents the error from showing up.