2 Replies Latest reply on Mar 15, 2007 3:21 PM by Claus Wittmann

    Cannot process metrics - BPEL-beta2

    Claus Wittmann Newbie

      Hi all!

      actually I'm fighting with a problem I cannot attach to a cause...

      I have two development machines (my and one of my collegue).
      We have the same options in our Developmentenvironment and I also tried to copy the second one completely on my machine. But I cannot get working my problem here.

      Ok what's up.

      I have running the jBoss 4.0.4GA with the jBpm and BPEL Extension Beta2.
      I have also an server.jar running in the jBoss.
      This "Server" gets a message from an clientapplication and send internally a SOAP message to the BPEL engine.

      This works fine on the machine of my collegue but not on my machine!
      I get everytime the following error:

      2007-03-14 10:47:00,000 ERROR [org.jboss.ws.server.ServiceEndpoint] Cannot process metrics
      java.lang.ClassCastException: org.jboss.ws.soap.SOAPBodyElementDoc


      OK - so I tried another way:
      I used the Web Service Analyse (a tool by which you can send SOAP messages) and connected myself to the BPEL-Engine.
      I can send exactly one message that should initiate a processexecution.
      Then I get the same error.
      The I can logon again and It works again for one more message - then the same error.

      Actually I do not know what to to next. I cannot find anything about this error.

      The big strange point: It works on the machine of my collegue. (And now I have tried a second one and it works neither...

      I hope someone can help me on this - maybe a hint about how the error "cannot process metrics" is created would be very helpfull.

      Greetings TNT