1 Reply Latest reply on May 2, 2007 10:16 AM by Cristi Macoviciuc

    Possible bug in conditions?

    M D Newbie

      We are (newbies) using 3.2 GA release of jBPM jdpl. We?ve found a strange behaviour using conditions in our process definitions. We have read previously posted topics regarding conditions but we didn?t find anything similar like this. Reading a processdefintion from file is completely ok, the conditions are used correctly in our process flow. But when we are reading the process definition from the database (exactly the same process definition as the file) the conditions are not used at all.

      The attribute nodes (list of nodes) contain all nodes with all conditions in both cases.

      This is what we found?

      When using a process definition from file (using ProcessDefinition.parseXmlInputStream(s) ) the process definition contains a transient attribute nodesMap, but when we are using a process definition from the jbpm database (using graphSession.findLatestProcessDefinition(processName) ) the nodesMap is null.

      When debugging these two different ways the only difference we?ve found is the nodesMap attribute. We have tried all methods to get process definitions from the database and all methods gives us same result (nodesMap = null). Is nodesMap used together with conditions? Is it a bug?