2 Replies Latest reply on Jul 2, 2007 3:20 AM by Ronald van Kuijk

    No JbpmConfiguration class def found in jBPM-jpdl 3.2.1

    masipu Newbie

      I'm trying to test 3.2.1 version and deployed a war file (that i have used for testing with 3.1.3 jbpm-starter-kit) that included simple servlet that created a new process instance. Servlet throws following error:

      10:28:54,020 ERROR [[XmlReceiver]] Servlet.service() for servlet XmlReceiver threw exception
      java.lang.NoClassDefFoundError: org/jbpm/JbpmConfiguration
      at com.sample.action.XmlReceiver.doGet(XmlReceiver.java:43)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:697)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
      at .....

      I tried to deploy the same servlet to jbpm-starter-kit as it is out-ot-the-box and it worked well. So what should I do to make it work in 3.2.1? I'm afraid I have missed something but the readme.html do say that "This is a preconfigured jboss 4.0.2 installation that contains jBPM." which is about the same as is says at starter kit also.. So in my opinion it should work "out-of-the-box".