2 Replies Latest reply on Jul 24, 2007 6:56 PM by Liuqing HUANG

    Problems of using JBoss jBPM invoking web services

    Liuqing HUANG Newbie

      I was trying to make JBPM invoking web services, but failed...

      I first tried to use BPEL1.1 beta3, after integrating BPEL and jBPM into JBossAS respectively, I found that BPEL and jBPM were using different DBschema. How can I make them work together, e.g. let the business process invoke the web service deployed by BPEL?

      And then I tried to deploy a web service by using XFire, and it was successful and it also passed the test to test invoking this web service. However I tried to invoke it from the business process by doing:

      <action class="com.myService.xfireDemo.InvokeService">


      When I actually invoke it when starting the business process, it shows an error message on the page:

      Error taking transition: com.myService.xfireDemo.InvokeService
       The application received a org.jbpm.graph.def.DelegationException.
       The message is: com.myService.xfireDemo.InvokeService


      Can anybody help with it? Thank you!