9 Replies Latest reply on Aug 6, 2007 8:20 PM by Jessica Dickinson Goodman

    JBPM 3.2.1 web app?does not display deployed process

    Jessica Dickinson Goodman Newbie

      Hi All,

      I'm running Eclipse 3.3.0 with the jbpm plugin 3.2.1

      I am having a problem viewing my deployed process definitions through the web app. My goal is to be able to interact with my process definition at localhost:8080/jbpm-console.

      I have tried deploying my process through the Eclipse IDE and through the web app, both unsuccessfully but with different output.

      When I deploy from the eclipse IDE the server is found with no problem and when I press the Deploy Process Archive button I receive the message "The process archive deployed successfully".

      However when I go to the web app and login as manager (I still haven't successfully edited the web.xml doc) I do not see my process.

      When I deploy from the Web App I go and find the xml file named "processdefinintion" (it's in a folder w/ the xml file of the gpd and the process image) and hit deploy. I then receive the error: "Error deploying process: An exception of type "org.jbpm.jpdl.JpdlException" was thrown. The message is: [[ERROR] no processdefinition.xml inside process archive]".

      I interpreted this to mean that the web app could not find a processdefinition.xml file. Thinking it might want a local process archive I saved a process archive locally but received the same error when I deployed that file.

      Here are the research steps I?ve taken:

      I Googled the error from the web app (using both a general search and a groups search) and the 2 JBoss forum suggestions which I have investigated were:

      The file might have xml syntax errors (I found that I did have some and I corrected all of the syntax errors and the problem continued). I also found a suggestion that it might be the size of the processdefinition which was causing the error and when I created a smaller test definition it deployed. However the next time I tried it failed?and I cannot think what I did differently to cause it.

      The console and the web app were not of the same version (this was also true but I updated both and the problem continued).

      http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4063137#4063137

      (As to the second part of the response to this question I think that has to do with a unrelated issue).

      I found this documentation:

      http://jsourcery.com/api/sourceforge/jbpm/3.1.2/src-html/org/jbpm/jpdl/par/JpdlArchiveParser.html

      Which seems to imply that the error I found on the web app is thrown when a user tries to upload a file which contains no data. However, as my file displays that it is 2 KB in size I am not sure this helps.

      Seeking inspiration, I looked at the console printout. I have copied the relevant section below.

      I tried getting to the WEB-INF file inside each jar file (I tried double-clicking the jar file) but was unsuccessful. I tried Googling the line

      ?com.sun.facelets.compiler.TagLibraryConfig loadImplicit?

      because it seemed to show up so often and found this JBoss Jira issue which said to ignore those errors.

      http://www.andromda.org/jira/browse/JSF-30

      This forum posting also said those errors can be ignored, however, having nothing else to go on, I?m still including it in case it proves helpful.

      http://www.icefaces.org/JForum/posts/list/4234.page

      The console printout which includes the errors reads:

      09:24:10,555 ERROR [STDERR] Jul 25, 2007 9:24:10 AM com.sun.faces.lifecycle.ELRe
      solverInitPhaseListener populateFacesELResolverForJsp
      INFO: JSF1027: [null] The ELResolvers for JSF were not registered with the JSP c
      ontainer.
      09:24:11,555 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jsf-facelets.jar!/META-INF/jstl-core.tagl
      ib.xml
      09:24:11,555 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jsf-facelets.jar!/META-INF/jstl-fn.taglib
      .xml
      09:24:11,617 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jsf-facelets.jar!/META-INF/jsf-html.tagli
      b.xml
      09:24:11,633 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/gravel-14.jar!/META-INF/gravel-nav.taglib
      .xml
      09:24:11,696 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/gravel-14.jar!/META-INF/gravel-simple.tag
      lib.xml
      09:24:11,727 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jbpm4jsf-14.jar!/META-INF/tfl.taglib.xml
      09:24:11,789 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/gravel-14.jar!/META-INF/gravel-compat.tag
      lib.xml
      09:24:11,883 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jbpm4jsf-14.jar!/META-INF/core.taglib.xml
      
      09:24:11,945 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jsf-facelets.jar!/META-INF/jsf-core.tagli
      b.xml
      09:24:11,992 ERROR [STDERR] Jul 25, 2007 9:24:11 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jsf-facelets.jar!/META-INF/jsf-ui.taglib.
      xml
      09:24:12,039 ERROR [STDERR] Jul 25, 2007 9:24:12 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/gravel-14.jar!/META-INF/gravel-action.tag
      lib.xml
      09:24:12,086 ERROR [STDERR] Jul 25, 2007 9:24:12 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jbpm4jsf-14.jar!/META-INF/identity.taglib
      .xml
      09:24:12,117 ERROR [STDERR] Jul 25, 2007 9:24:12 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jbpm4jsf-14.jar!/META-INF/tf-compat.tagli
      b.xml
      09:24:12,180 ERROR [STDERR] Jul 25, 2007 9:24:12 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/gravel-14.jar!/META-INF/gravel-data.tagli
      b.xml
      09:24:12,195 ERROR [STDERR] Jul 25, 2007 9:24:12 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jbpm4jsf-14.jar!/META-INF/tf.taglib.xml
      09:24:12,211 ERROR [STDERR] Jul 25, 2007 9:24:12 AM com.sun.facelets.compiler.Ta
      gLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/C:/Documents%20and%20Settings/jdickins/Deskt
      op/JBPM-IDE%202.0/suite%203.2.1/jbpm-jpdl-3.2.1/server/server/jbpm/tmp/deploy/tm
      p37355jbpm-console-exp.war/WEB-INF/lib/jbpm4jsf-14.jar!/META-INF/tfl-compat.tagl
      ib.xml
      09:24:12,242 INFO [SessionFactoryObjectFactory] Not binding factory to JNDI, no
       JNDI name configured
      09:24:12,836 WARN [FromElementType] Using non-qualified column reference [isSus
      pended -> ([ISSUSPENDED_])]
      09:24:12,836 WARN [FromElementType] Using non-qualified column reference [token
       -> ([TOKEN_])]
      09:24:13,054 WARN [FromElementType] Using non-qualified column reference [proce
      ssInstance -> ([PROCESSINSTANCE_])]
      09:24:13,086 WARN [FromElementType] Using non-qualified column reference [id ->
       ([ID_])]
      09:24:13,086 WARN [FromElementType] Using non-qualified column reference [proce
      ssInstance -> ([PROCESSINSTANCE_])]
      09:24:13,101 WARN [FromElementType] Using non-qualified column reference [proce
      ssInstance -> ([PROCESSINSTANCE_])]
      09:24:13,101 WARN [FromElementType] Using non-qualified column reference [isSus
      pended -> ([ISSUSPENDED_])]
      09:24:13,101 WARN [FromElementType] Using non-qualified column reference [token
       -> ([TOKEN_])]


      I have also read through the relevant jbpm wikis and gone through the GettingStarted Guide again with no luck.

      The web app displays my additions to the sql tables just fine and I can run the websale example and the small processdefinition I successfully deployed just fine. However when I try to deploy new processdefinitions I receive the above error through the web app and code on the server console.

      Would someone provide a pointer to where I can look next? Thanks for your attention,

        • 1. Re: JBPM 3.2.1 web app?does not display deployed process
          Koen Aers Master

          Were you able to deply the simple example process that is available when you create a new jBPM project with the plugin?
          Also, what is the version of your jBPM runtime?

          Regards,
          Koen

          • 2. Re: JBPM 3.2.1 web app?does not display deployed process
            Jessica Dickinson Goodman Newbie

            I was unsuccessful in deploying the getting started example. I also tried the InsuranceRuleFlow example and it deployed successfully from the IDE and then did not display on the web app. I received the same error message for both process definitions when I attempted to deploy them from the web app.

            My jbpm runtime is 3.2.1 (I downloaded jpdl suite 3.2.1).

            Thanks for your attention,

            • 3. Re: JBPM 3.2.1 web app?does not display deployed process
              Jessica Dickinson Goodman Newbie

              I found this post:

              http://www.jboss.com/index.html?module=bb&op=viewtopic&t=109765&postdays=0&postorder=asc&start=10

              Which referenced an ant build (last post of the thread). I'm going to work through this documentation:

              http://www.jboss.com/products/jbpm/docs/deployment

              To see if the other deployment options work.

              On the suggestion of a friend I found some more syntax errors (still figuring out how to implement the mail actions using templates) which didn't cause any change in error messages. I also used windows task manager to see if I was running multiple servers and therefore deploying successfully to the one which was not being referenced by the web app, but as far as I could tell this was not the case.

              Does anyone has any suggestions about where I could look next for a solution?

              Thanks for your time,

              • 4. Re: JBPM 3.2.1 web app?does not display deployed process
                Matthew Sandoz Newbie

                 


                When I deploy from the Web App I go and find the xml file named "processdefinintion" (it's in a folder w/ the xml file of the gpd and the process image) and hit deploy. I then receive the error: "Error deploying process: An exception of type "org.jbpm.jpdl.JpdlException" was thrown. The message is: [[ERROR] no processdefinition.xml inside process archive]".


                have you tried deploying locally? when you do you will notice that what is deployed is a zip containing the process definition and other files. if you can create that, try to upload it to the server. the server will unpack the file and find the process definition inside. That may not be the root of your issues, but its one thing you can change.

                • 5. Re: JBPM 3.2.1 web app?does not display deployed process
                  Jessica Dickinson Goodman Newbie

                  Hi,

                  Thank you for the suggestion, I will try it. However, before when I've tried saving my process archive locally (pressing the button marked "save process archive locally") and when I deployed that from the web app I got the same error message as when I deployed just the process definition. Is that method what you meant?

                  I'm going to work through this documentation:
                  http://www.jboss.com/products/jbpm/docs/deployment
                  To see if the other deployment options work.


                  The document I found yesterday, while being interesting, did not seem to help my problem as it is not deployment in different environments that I am having a problem with but deployment in any environment.

                  I think the first replier was on the right track: I may have a mismatch between my Runtime and my jbpm suite although I thought I'd fixed that problem.

                  Looking at the basic documentation again,

                  http://docs.jboss.com/jbpm/v3/userguide/gettingstarted.html#downloadablesoverview

                  I have the feeling in my initial set up I may have inaccurately set up the relationships between Eclipse and the Runtime and the jbpm suite. I am going to un-install and re-install on Monday and see what comes of it.

                  On a side note, when I am deploying, I have set my "Server Deployer" to "/jbpm-console" rather than"/jbpm-console/upload" because 1) that way it matches the url I use to view the web app and 2) when I deployed to "/jbpm-console/upload" I received an error which I thought indicated that it could not find "http://localhost:8080/jbpm-console/upload". This lead me to try to get the information I inputed into the deployment fields the match the url I was going to (duh). When I tried deploying to "/jbpm-console" I recvied no error. And my process definition did not display. I can post the error message I received when I deployed to the /upload Server Deployer if it is relevant.

                  I am a little nervous about this change because it goes against what the jbpmGettingStarted guide says, but it does cause my process to say that it deployed successfully.

                  Thank you to everyone who has commented on my question. Any thoughts on this or any other aspect of this problem would be appreciated.


                  • 6. Re: JBPM 3.2.1 web app?does not display deployed process
                    Jessica Dickinson Goodman Newbie

                    Hey all,

                    I am still getting the same error I started out with and am still unable to get my process definition to display on the jBPM web app.

                    Here are the steps I've taken thus far
                    1) I downloaded a new copy of Eclipse (Version: 3.2.2)
                    2) Downloaded jbpm runtime and suite (both 3.2.1).
                    3) Setting the runtime (Window-> Preferences-> Jbpm-> JBPM Runtime) to ?JBoss Jbpm Runtime 3.2.1?
                    4) Deleting my old versions of jbpm (starter kit 3.1.3 and 3.2.1) and Eclipse (3.3)
                    5) Using the advice in this post

                    http://www.jboss.com/index.html?module=bb&op=viewtopic&p=3963971#3963971

                    5 cont.) to deal w/ the message I received upon startup with my new eclipse "An internal error occurred during: "Initializing Java tooling"". The stack trace I had was exactly the same as the one in the forum post above. Is there a Jira Issue for this? I searched the Jira site using max.andersen@jboss.com?s name and the date range I thought it might have been reported in and found nothing. Not a big deal as the forum post covers how to fix the problem pretty extensively.
                    6) Resetting the workspace (cleared up the other errors I had been experiencing)
                    7) Importing my project from my previous workspace
                    8) Attempted to deploy my project.

                    I attempted to deploy the processdefinition from the web app and received the error:


                    Error deploying process: An exception of type "org.jbpm.jpdl.JpdlException" was thrown. The message is: [[ERROR] no processdefinition.xml inside process archive]


                    Thanks to msandoz, I tried deploying locally in Eclipse. When I deployed the process archive from the web app it produced the an error (but was still more constructive than the processdefinition error ;-D). Here is the error it produced:

                    Error deploying process: An exception of type "org.jbpm.jpdl.JpdlException" was thrown. The message is: [[ERROR] couldn't parse process definition]


                    When I try to deploy from Eclipse's deployment tab I receive the error:

                    An exception happened during the deployment of the process. Reason: an unexpected exception caused the deployment to fail.


                    Here is the stack-trace:

                    java.io.FileNotFoundException: http://localhost:8080/jbpm/upload
                    at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)
                    at org.jbpm.ui.util.ProcessDeployer.deployProcessWithServlet(Unknown Source)
                    at org.jbpm.ui.util.ProcessDeployer.access$3(Unknown Source)
                    at org.jbpm.ui.util.ProcessDeployer$1.run(Unknown Source)
                    at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:369)
                    at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:313)
                    at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:479)
                    at org.jbpm.ui.util.ProcessDeployer.showProgressMonitorDialog(Unknown Source)
                    at org.jbpm.ui.util.ProcessDeployer.deploy(Unknown Source)
                    at org.jbpm.ui.editor.form.deployment.DeploymentForm$1.widgetSelected(Unknown Source)
                    at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:90)
                    at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
                    at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:928)
                    at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3348)
                    at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2968)
                    at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1930)
                    at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1894)
                    at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:422)
                    at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:149)
                    at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:95)
                    at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:78)
                    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:92)
                    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:68)
                    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
                    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:177)
                    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                    at java.lang.reflect.Method.invoke(Unknown Source)
                    at org.eclipse.core.launcher.Main.invokeFramework(Main.java:336)
                    at org.eclipse.core.launcher.Main.basicRun(Main.java:280)
                    at org.eclipse.core.launcher.Main.run(Main.java:977)
                    at org.eclipse.core.launcher.Main.main(Main.java:952)


                    In my current IDE version, other than changing my jbpm server preferences, I am not sure how to tell the IDE to deploy to jbpm-console instead of jbpm/deploy (which appears to be the first complain in the stack trace). This, however, is a side issue to the main issue that I still cannot view my process definition from the site localhost:8080/jbpm-console.

                    It is because of this that I attempted to deploy from the web app, but as I previously stated, received the same error as before.

                    If anyone has any thoughts about how to get my locally saved process archive to display on the Web App I would be most grateful. Thanks again to everyone who has spent time thinking about this thread.

                    • 7. Re: JBPM 3.2.1 web app?does not display deployed process
                      Matthew Sandoz Newbie

                      i dont know if this would help but is it possible to post your process? also if instead of using the suite, you can get the code from cvs and import it into eclipse and then debug the editor as an eclipse app, that might give you more insight into whats going on.

                      • 8. Re: JBPM 3.2.1 web app?does not display deployed process
                        jeffcwang Newbie

                        Hi Jdickens,

                        I have also just started evaluating jbpm and have worked through similar problems as you. I was (finally) able to get it working. My set up is as follows:

                        Eclipse Europa 3.3
                        JBPM Suite 3.2.1
                        JBPM Designer Ecplipse Plugin 3.013 (org.jbpm.gd.jpdl.feature in the ecliplse plugin manager)
                        JBoss Eclipse IDE 1.6.0.GA (not sure if you need this)

                        In response to your question about changing the deploy directory, you need to have the latest plug-in of the designer (3.013). When you have this, you will have an extra "Server Deployer" field in the deployment tab. I was running an older version (3.09) before and it didn't have that. What version of the plug-in do you have?

                        The process I deployed was the holiday-request process in the video on the main page (http://docs.jboss.com/jbpm/v3/demos/movies/jbpm-overview.htm). However, once you get it deployed you will see that the screen shots and video are nothing alike. It looks like the UI has changed in this version. I cannot get the UI to display the control field associated with each task correctly. Maybe you can help me out when you get to this step.

                        • 9. Re: JBPM 3.2.1 web app?does not display deployed process
                          Jessica Dickinson Goodman Newbie

                          Hey all,

                          I am sorry to leave everyone hanging but I have been a temporary developer for a US university for the past 2 months and my job ends today. I would like to thank everyone, jeffcwang, msandoz and Koen for all of the help you have given me. My supervisor may come back to this post, but as deployment is working on her machine I'm not sure she will.

                          Sorry, but as my process definition is made up from a process tons of other people developed, I don't think it would be right to post my process definition without their permission (and they haven't gotten back to me about giving it).

                          And jeffcwang, if I'm reading you problem right you might want to check out the relationship between the the task controller and fields associated with each task in the getting started wiki:

                          http://wiki.jboss.org/wiki/Wiki.jsp?page=JbpmGettingStarted

                          Obviously you're way beyond the basics of this document, but I have found it actually pretty rich in help when attempting to diagnose faulty behavior.

                          As I understand it task-variables are what appear next to the writable boxes in the web app-- ie, in the old websale example, the input field where cookie monster wrote the number of cookies he wanted, word "amount" was what the jbpm user inputed as a task-variable when the workflow was being designed initially. Sections 11.4 and 11.5 of the jbpm userguide might help here.

                          http://docs.jboss.com/jbpm/v3/userguide/taskmanagement.html#taskinstancevariables

                          In the response to your other question, I have plugin version 3.2.1. When I was using Europa I had the "server deployer" section in my deployment tab. In 3.2 I think I can which server I am deploying to using the path Windows-> Preferences->JBoss jBPM->Runtime locations. This also works in Europa. The UI has changed 3 times in my time working w/ jBPM. I think at least once it was because I changed versions. It turns out (at least for what I'm doing) that the web app (which I think is only meant to be a sample and is supposed to be customized by users who wish to do so) is functional no matter what the UI looks like.

                          Anyway, Thanks again to all the jBPM folks. Learning from ya'll is a lot more interactive, varied and intense than learning in school. Which is what I'll be doing next. Thanks again!

                          From Jessica