2 Replies Latest reply on Aug 25, 2007 11:53 AM by Wolfgang Hollweck

    ant task for process archive deploying - Wiki?

    M. S. Newbie

      Hi at all,

      I have the following problem:
      I would like to deploy an process archive with an ant task. I have found the corresponding chapter in the jBPM jPDL 3.2 User Guide and tried to build my own build.xml. But I'm not so familiar with this ant stuff and I'm still getting the exception that the org.jbpm.ant.DeployParTask cannot be found.

      Is there someone out there who can just give me a small ant snippet to solve this problem? And wouldn't it be great to have such an ant task in the wiki for every people that have the same problem? Maybe the JbpmExampleApplications would be the right place.

      thanks in advance
      lou

        • 1. Re: ant task for process archive deploying - Wiki?
          M. S. Newbie

          Hello again,

          I have created an build.xml that runs correct. At least I got an *BUILD SUCCESSFUL*.

          The problem first was that the class org.jbpm.ant.DeployParTask doesn't exist in jbpm-3.1.2. It's now called DeployProcessTask. And the deploy parameter par now is called process. Thanks to the User Guide I wasted 3 hours to find this problem.

          After that the build still wasn't succesful. I got a *BUILD FAILED* because the jbpm tables were not found (i guess). So I put the following additional property to my hibernate.cfg.xml file.

          <property name="hibernate.hbm2ddl.auto">create-drop</property>
          

          Now the build runs. I get this *BUILD SUCCESSFUL* message.

          But the process definition is still not deployed!! I have checked the PUBLIC.JBPM_PROCESSDEFINITION table with the HSQL Database Manager but there is still only the websale process deployed.

          Does anybody has an idea what to do? I thought it must be easier to do this deployment.

          thanks
          lou

          • 2. Re: ant task for process archive deploying - Wiki?
            Wolfgang Hollweck Newbie

            The process gets deployed, probably...

            Set

            <property name="hibernate.hbm2ddl.auto">create-drop</property>
            

            to
            <property name="hibernate.hbm2ddl.auto">create</property>
            

            as 'create-drop' drops the built schema again when closing the connection to the DB.
            See the Hibernate docs for this.

            I'll create a JIRA Entry for the buggy, missleading Userguide due to the ant task, as well.
            I had the same problem...