5 Replies Latest reply on Oct 9, 2007 6:13 PM by Chris LeCompte

    Problem deploying jbpm-console

    Lars Vonk Newbie

      Hi all,

      I recently tried to deploy the jbpm-console (jbpm-enterprise.ear) packaged in the jbpm-jpdl-suite-3.2.GA.zip. And came across the following problems, I use JBOSS 4.0.5 GA and JDK 1.5.0_11:

      - The readme.html in the jbpm-jpdl-suite-3.2.GA/deploy is very summier. It promises an out-of-the-box deployment but that is not really the case.

      - When hot deploying the ear file and navigating to the login page I get a NullPointerException:

      08:28:33,305 ERROR [STDERR] 10/09/2007 08:28:33 com.sun.facelets.FaceletViewHandler handleRenderException
      SEVERE: Error Rendering View[/common/login.xhtml]
      java.lang.NullPointerException
      


      - After restarting JBOSS it doesnot give me a NullPointer anymore but I still see these error messages in my console:
      08:39:21,448 ERROR [STDERR] 12/09/2007 08:39:21 com.sun.faces.lifecycle.ELResolverInitPhaseListener populateFacesELResolverForJsp
      INFO: JSF1027: [null] The ELResolvers for JSF were not registered with the JSP container.
      08:39:24,727 ERROR [STDERR] 12/09/2007 08:39:24 com.sun.facelets.compiler.TagLibraryConfig loadImplicit
      INFO: Added Library from: jar:file:/home/lars/tools/jboss-4.0.5.GA/server/default/./tmp/deploy/tmp21907jbpm-enterprise.ear-contents/jbpm-console-exp.war/WEB-INF/lib/jsf-facelets.jar!/META-INF/jsf-html.taglib.xml
      


      - When I try to login I get this error message in my console:
      08:32:11,669 ERROR [UsersRolesLoginModule] Failed to load users/passwords/role files
      java.io.IOException: No properties file: users.properties or defaults: defaultUsers.properties found
      at org.jboss.security.auth.spi.Util.loadProperties(Util.java:315)
      

      Someone replied on a blog I wrote to add the jbpm authentication policy that can be found in login-config.xml in the jbpm-jpdl-suite-3.2.GA.zip. I tried this, it does not give me the error in the console anymore but I am still not able to login. The page just keeps telling me borrow some glasses...

      My login-config.xml:

       <application-policy name = "jbpm">
      
       <authentication>
      
       <login-module code="org.jboss.security.auth.spi.DatabaseServerLoginModule"
      
       flag="required">
      
       <module-option name="dsJndiName">java:/JbpmDS</module-option>
      
       <module-option name="principalsQuery">
      
       SELECT PASSWORD_ FROM JBPM_ID_USER WHERE NAME_=?
      
       </module-option>
      
       <module-option name="rolesQuery">
      
       SELECT g.NAME_ ,'Roles'
      
       FROM JBPM_ID_USER u,
      
       JBPM_ID_MEMBERSHIP m,
      
       JBPM_ID_GROUP g
      
       WHERE g.TYPE_='security-role'
      
       AND m.GROUP_ = g.ID_
      
       AND m.USER_ = u.ID_
      
       AND u.NAME_=?
      
       </module-option>
      
       </login-module>
      
       </authentication>
      
       </application-policy>
      


      I then tried to copy the jbpm-jpdl-3.2.GA/server/server/jbpm to my existing JBOSS server and start that one. This gives me a:

      09:09:39,241 ERROR [STDERR] java.lang.NoClassDefFoundError: org/dom4j/DocumentException
      09:09:39,241 ERROR [STDERR] at org.jbpm.db.hibernate.HibernateHelper.createConfiguration(HibernateHelper.java:85)
      


      After I copied the dom4j.jar into the server/jbpm/lib folder it started without errors and I am able to login. I do believe the dom4j adding to the lib is mentioned somewhere but I wonder why it is not already in the server/jbpm/lib folder?

      regards,
      Lars

        • 1. Re: Problem deploying jbpm-console
          James Baxter Newbie

          jbpm-jpdl-suite-3.2.1 was released in June and is much more stable, so Id try that next time you come up against any problems!

          • 3. Re: Problem deploying jbpm-console
            Ronald van Kuijk Master

            @Ivonk:
            You should not have to configure the login policy in the suite. The suite IS ready to run out of the box INCLUDING the JBoss AS server it has in it. At least it does for me each time I test a release. If you use your own JBOss AS, your milage may indeed vary and you have to do more configuration. Lots of that in the wiki btw.

            @jbaxter:
            There were some minor, wel reported issues with the 3.2.1 release. So to say it is much more stable....

            regarding the download... unfortunately a rergession in the site. Try labs.jboss.com and then via projects or resources... that contains the correct ones (or direct at the SF.NET site

            • 4. Re: Problem deploying jbpm-console
              Koen Aers Master

              Indeed, go to our labs pages for downloads: http://labs.jboss.org/jbossjbpm/downloads.

              The website is being completely restructured and the labs pages will be the place to download files, find docs, etc. The jboss.com site will be used purely for marketing purposes in the future.

              Sorry for the inconvenience...

              Regards,
              Koen

              • 5. Re: Problem deploying jbpm-console
                Chris LeCompte Newbie

                I'm currently trying to deploy the 3.2.2 jbpm-enterprise.ear in a jboss application server configured to use the JBossWebClassloader (it needs to since another app depends on this). I have moved the myfaces jars to the jbpm-console.war/WEB-INF/lib directory within the ear and added a jboss-app.xml file to partition the class loader for the ear. This setup seems to work fine on my local machine which is windows XP using the JBOSS supplied with the suite (modified accordingly). On Solaris however, I receive the error:

                http-0.0.0.0-18950-1 2007-10-09 18:12:22,097 | ERROR | session= | user= | org.apache.catalina.core.ContainerBase.[jboss.web].[localhost].[/jbpm-console].[Faces Servlet] | Servlet.service() for servlet Faces Servlet threw exception
                java.lang.NullPointerException
                 at com.sun.faces.lifecycle.ELResolverInitPhaseListener.populateFacesELResolverForJsp(ELResolverInitPhaseListener.java:135)
                 at com.sun.faces.lifecycle.ELResolverInitPhaseListener.beforePhase(ELResolverInitPhaseListener.java:100)
                 at org.apache.myfaces.lifecycle.LifecycleImpl.informPhaseListenersBefore(LifecycleImpl.java:520)
                 at org.apache.myfaces.lifecycle.LifecycleImpl.restoreView(LifecycleImpl.java:105)
                 at org.apache.myfaces.lifecycle.LifecycleImpl.execute(LifecycleImpl.java:66)
                 at javax.faces.webapp.FacesServlet.service(FacesServlet.java:244)


                On the windows server instance I get a similar related message but the application appears fine and I can log in:

                2007-10-09 18:09:52,770 ERROR [STDERR] Oct 9, 2007 6:09:52 PM com.sun.faces.lifecycle.ELResolverInitPhaseListener populateFacesELResolverForJsp
                INFO: JSF1027: [null] The ELResolvers for JSF were not registered with the JSP container.


                Could this be dependent upon the data source? I have switched that to use an Oracle schema generated using the supplied database scripts.

                Also, the version of the target JBOSS instance is 4.0.4 GA (the same build as the suite's server).