3 Replies Latest reply on Oct 10, 2007 7:57 PM by Alejandro Guizar

    Help with Bpel error - "process.bpel activity not found"

    Daniel Epstein Newbie

      Hello, I finally got the helloWorld.bpel service deployed in 4.0.4.GA. using the 1.1beta3 bpel engine.
      I can deploy all of the examples, but when I try to create a process from scratch I get
      10:28:21,140 INFO [BpelReader] read bpel process: EchoService.bpel
      10:28:21,140 ERROR [[processDeployServlet]] Servlet.service() for servlet processDeployServlet threw exception
      org.jbpm.jpdl.JpdlException: [[ERROR] EchoService.bpel activity not found [/process]]

      Can someone please elaborate on this error message and what might be causing it?

        • 1. Re: Help with Bpel error -
          Alejandro Guizar Master

          "activity not found" means no activity element was found as a child of the element in square brackets, in this case process. Can you please post your BPEL document to examine it and try to help you a bit more?

          • 2. Re: Help with Bpel error -
            Daniel Epstein Newbie

             

            <?xml version="1.0" encoding="UTF-8"?>
            <process
             name="newProcess"
             targetNamespace="http://enterprise.netbeans.org/bpel/ScratchBpelModule1/newProcess"
             xmlns="http://docs.oasis-open.org/wsbpel/2.0/process/executable"
             xmlns:xsd="http://www.w3.org/2001/XMLSchema"
             xmlns:tns="http://enterprise.netbeans.org/bpel/ScratchBpelModule1/newProcess" xmlns:ns1="http://j2ee.netbeans.org/wsdl/newWSDL">
             <import namespace="http://j2ee.netbeans.org/wsdl/newWSDL" location="newWSDL.wsdl" importType="http://schemas.xmlsoap.org/wsdl/"/>
             <partnerLinks>
             <partnerLink name="PartnerLink1" partnerLinkType="ns1:newWSDL1" myRole="newWSDLPortTypeRole"/>
             </partnerLinks>
             <variables>
             <variable name="NewWSDLOperationOut" messageType="ns1:newWSDLOperationReply"/>
             <variable name="NewWSDLOperationIn" messageType="ns1:newWSDLOperationRequest"/>
             </variables>
             <sequence>
             <receive name="Receive1" createInstance="yes" partnerLink="PartnerLink1" operation="newWSDLOperation" portType="ns1:newWSDLPortType" variable="NewWSDLOperationIn"/>
             <assign name="Assign1">
             <copy>
             <from variable="NewWSDLOperationIn" part="part1"/>
             <to variable="NewWSDLOperationOut" part="part1"/>
             </copy>
             </assign>
             <reply name="Reply1" partnerLink="PartnerLink1" operation="newWSDLOperation" portType="ns1:newWSDLPortType" variable="NewWSDLOperationOut"/>
             </sequence>
            </process>


            Here' s my wsdl:
            <?xml version="1.0" encoding="UTF-8"?>
            <definitions name="newWSDL" targetNamespace="http://j2ee.netbeans.org/wsdl/newWSDL"
             xmlns="http://schemas.xmlsoap.org/wsdl/"
             xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
             xmlns:xsd="http://www.w3.org/2001/XMLSchema"
             xmlns:tns="http://j2ee.netbeans.org/wsdl/newWSDL"
             xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype"
             xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/">
             <types>
             <xsd:schema targetNamespace="http://j2ee.netbeans.org/wsdl/newWSDL">
             <xsd:complexType name="Shape">
             <xsd:sequence>
             <xsd:element name="size" type="xsd:int"></xsd:element>
             </xsd:sequence>
             </xsd:complexType>
             <xsd:element name="square" type="tns:Shape"></xsd:element>
             </xsd:schema>
             </types>
             <message name="newWSDLOperationRequest">
             <part name="part1" element="tns:square"/>
             </message>
             <message name="newWSDLOperationReply">
             <part name="part1" element="tns:square"/>
             </message>
             <portType name="newWSDLPortType">
             <operation name="newWSDLOperation">
             <input name="input1" message="tns:newWSDLOperationRequest"/>
             <output name="output1" message="tns:newWSDLOperationReply"/>
             </operation>
             </portType>
             <plnk:partnerLinkType name="newWSDL1">
             <plnk:role name="newWSDLPortTypeRole" portType="tns:newWSDLPortType"/>
             </plnk:partnerLinkType>
            </definitions>




            • 3. Re: Help with Bpel error -
              Alejandro Guizar Master

              For compatibility with the Eclipse BPEL designer, jBPM BPEL supports an early draft of the WS-BPEL 2.0 specification instead of the approved standard. The schema accepted by the product can be found in jbpm-bpel.jar. Look for resource org/jbpm/bpel/xml/util/bpel_2_0.xsd.

              The documents you provided mostly adhere to the above schema, except for the bpel and plnk namespaces. In the BPEL document, replace:

              xmlns="http://docs.oasis-open.org/wsbpel/2.0/process/executable"

              with
              xmlns="http://schemas.xmlsoap.org/ws/2004/03/business-process/"

              In the WSDL document, replace:
              xmlns:plnk="http://docs.oasis-open.org/wsbpel/2.0/plnktype"

              with
              xmlns:plnk="http://schemas.xmlsoap.org/ws/2004/03/partner-link/"

              This should fix the problem.