1 Reply Latest reply on Jan 15, 2008 11:15 AM by Wolfgang Hollweck

    Deployment process ant task

    Albrecht Olivier Newbie

      Hello,

      I am trying to deploy my process made with JBPM 3.2 on MySQL 5 with the ant task. When I launch my task :

       <target name="deploy.process" depends="jarizer">
       <taskdef name="deployprocess" classname="org.jbpm.ant.DeployProcessTask">
       <classpath>
       <pathelement path="D:\java\jbpm-jpdl-3.2.GA\jbpm-jpdl.jar" />
       <pathelement path="D:\java\jbpm-jpdl-3.2.GA\lib\commons-logging.jar" />
       <pathelement path="D:\java\jbpm-jpdl-3.2.GA\lib\dom4j.jar" />
       <pathelement path="D:\java\jbpm-jpdl-3.2.GA\lib\hibernate3.jar" />
       <pathelement path="D:\java\jbpm-jpdl-3.2.GA\server\server\jbpm\lib\mysql-connector-java-3.1.7-bin.jar" />
       <pathelement path="${PATH_PROJET}\bin\hibernate.cfg.xml" />
       <pathelement path="${PATH_PROJET}\bin\jbpm.cfg.xml" />
       </classpath>
       </taskdef>
      
       <deployprocess jbpmcfg="${PATH_PROJET}\bin\hibernate.cfg.xml" process="process.par">
      
       </deployprocess>
      


      An error occurs :
      deploy.process:
      [deployprocess] 3 oct. 2007 14:49:26 org.jbpm.JbpmConfiguration getInstance
      [deployprocess] INFO: using jbpm configuration resource 'D:\projets\test\bin\hibernate.cfg.xml'
      [deployprocess] deploying par D:\projets\test\jar\process.par ...
      [deployprocess] 3 oct. 2007 14:49:27 org.jbpm.jpdl.xml.JpdlXmlReader addWarning
      [deployprocess] ATTENTION: process xml warning: warning: no swimlane or assignment specified for task '<task xmlns="urn:jbpm.org:jpdl-3.2" name="2 params" blocking="false" signalling="true" priority="normal">
      [deployprocess] <controller config-type="field">
      [deployprocess] <variable name="paramNormal1" access="read,write"/>
      [deployprocess] <variable name="paramNormal2" access="read,write,required"/>
      [deployprocess] </controller>
      [deployprocess] </task>'
      [deployprocess] 3 oct. 2007 14:49:27 org.hibernate.cfg.Environment <clinit>
      [deployprocess] INFO: Hibernate 3.2.1
      [deployprocess] 3 oct. 2007 14:49:27 org.hibernate.cfg.Environment <clinit>
      [deployprocess] INFO: hibernate.properties not found
      [deployprocess] 3 oct. 2007 14:49:27 org.hibernate.cfg.Environment buildBytecodeProvider
      [deployprocess] INFO: Bytecode provider name : cglib
      [deployprocess] 3 oct. 2007 14:49:27 org.hibernate.cfg.Environment <clinit>
      [deployprocess] INFO: using JDK 1.4 java.sql.Timestamp handling
      [deployprocess] 3 oct. 2007 14:49:27 org.hibernate.cfg.Configuration configure
      [deployprocess] INFO: configuring from resource: hibernate.cfg.xml
      [deployprocess] 3 oct. 2007 14:49:27 org.hibernate.cfg.Configuration getConfigurationInputStream
      [deployprocess] INFO: Configuration resource: hibernate.cfg.xml
      [deployprocess] org.hibernate.HibernateException: hibernate.cfg.xml not found
      [deployprocess] at org.hibernate.util.ConfigHelper.getResourceAsStream(ConfigHelper.java:147)
      [deployprocess] at org.hibernate.cfg.Configuration.getConfigurationInputStream(Configuration.java:1402)
      [deployprocess] at org.hibernate.cfg.Configuration.configure(Configuration.java:1424)
      [deployprocess] at org.jbpm.db.hibernate.HibernateHelper.createConfiguration(HibernateHelper.java:91)
      [deployprocess] at org.jbpm.persistence.db.DbPersistenceServiceFactory.getConfiguration(DbPersistenceServiceFactory.java:69)
      [deployprocess] at org.jbpm.persistence.db.DbPersistenceServiceFactory.getSessionFactory(DbPersistenceServiceFactory.java:91)
      [deployprocess] at org.jbpm.persistence.db.DbPersistenceService.getSessionFactory(DbPersistenceService.java:94)
      [deployprocess] at org.jbpm.persistence.db.DbPersistenceService.getSession(DbPersistenceService.java:98)
      [deployprocess] at org.jbpm.persistence.db.DbPersistenceService.getGraphSession(DbPersistenceService.java:334)
      [deployprocess] at org.jbpm.JbpmContext.getGraphSession(JbpmContext.java:571)
      [deployprocess] at org.jbpm.JbpmContext.deployProcessDefinition(JbpmContext.java:173)
      [deployprocess] at org.jbpm.ant.DeployProcessTask.deploy(DeployProcessTask.java:93)
      [deployprocess] at org.jbpm.ant.DeployProcessTask.execute(DeployProcessTask.java:58)
      [deployprocess] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
      [deployprocess] at sun.reflect.GeneratedMethodAccessor1.invoke(Unknown Source)
      [deployprocess] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      [deployprocess] at java.lang.reflect.Method.invoke(Method.java:324)
      [deployprocess] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:105)
      [deployprocess] at org.apache.tools.ant.Task.perform(Task.java:348)
      [deployprocess] at org.apache.tools.ant.Target.execute(Target.java:357)
      [deployprocess] at org.apache.tools.ant.Target.performTasks(Target.java:385)
      [deployprocess] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1329)
      [deployprocess] at org.apache.tools.ant.Project.executeTarget(Project.java:1298)
      [deployprocess] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
      [deployprocess] at org.eclipse.ant.internal.ui.antsupport.EclipseDefaultExecutor.executeTargets(EclipseDefaultExecutor.java:32)
      [deployprocess] at org.apache.tools.ant.Project.executeTargets(Project.java:1181)
      [deployprocess] at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.run(InternalAntRunner.java:423)
      [deployprocess] at org.eclipse.ant.internal.ui.antsupport.InternalAntRunner.main(InternalAntRunner.java:137)
      
      BUILD FAILED
      D:\projets\test\jar\build.xml:86: couldn't deploy process archives : hibernate.cfg.xml not found
      


      I don't understand because on my process.par you can find my hibernate.cfg.xml on the root directory, I tryed also to specify the hibernate file path but the error is steel on.

      I tryed to find this answer on the userguide, on the deployment doc and on the forum but i didn't find something what works.

      Can somebody help me... I would like to know how to make my process.par ?

      Thanks