1 Reply Latest reply on Oct 9, 2007 10:09 AM by Ronald van Kuijk

    Delegation Class Problems (Repost)

    Thomas Brough Newbie

      I have desgined a very small workflow using eclipse. I have incorporated an assignment class to delegate a task to a particular user. All micky mouse stuff but I am getting the following in JBOSS log

      ERROR [Delegation] couldn't load delegation class ''

      and this from the web page :-

      Error starting process: An exception of type "org.jbpm.graph.def.DelegationException" was thrown.

      Now this is my processdefinition.xml

      <?xml version="1.0" encoding="UTF-8"?>
      
      <process-definition
       xmlns="urn:jbpm.org:jpdl-3.2"
       name="IT01">
       <swimlane name="initiator">
       <assignment class=""></assignment>
       </swimlane>
       <swimlane name="ITManager">
       <assignment class=""></assignment>
       </swimlane>
       <start-state name="start">
       <transition name="transition1" to="getDetails"></transition>
       </start-state>
       <end-state name="end"></end-state>
       <task-node name="getDetails">
       <task name="getDetails" swimlane="initiator"></task>
       <transition name="Transition2" to="Check Form">
       </transition>
       </task-node>
       <task-node name="Check Form">
       <task name="ITManagerFormCheck">
       <assignment class="uk.gov.torbay.it01.jbpm.ITManagerAssignment">
       <actor>manager</actor>
       </assignment>
       </task>
       <transition name="Transition3" to="end"></transition>
       </task-node>
      </process-definition>




      and this is the source of my uk.gov.torbay.it01.jbpm.ITManager Assignment class.
      package uk.gov.torbay.it01.jbpm;
      
      import org.jbpm.graph.exe.*;
      import org.jbpm.taskmgmt.def.*;
      import org.jbpm.taskmgmt.exe.Assignable;
      
      public class ITManagerAssignment implements AssignmentHandler {
      
       private static final long serialVersionUID = 1L;
      
       private String actor;
      
       public ITManagerAssignment()
       {
       }
       public void assign(Assignable assignable, ExecutionContext executionContext) {
       assignable.setActorId("manager");
       }
      public String getActor() {
       return actor;
      }
      public void setActor(String actor) {
       this.actor = actor;
      }
      
      }
      


      From the above error It would appear I have a parsing problem with the processdefinition.xml file since it seems to be trying to load a null class path/name.

      Anyone got any ideas where I am going wrong here ?

      The Eclipse deploy seems to indicate everything is ok so I am not sure whate to believe here.

      Appologies for repost I quoted the code instead of coding it and it didnt like it, price you pay for not previewing things in the first place.

      Tom.