4 Replies Latest reply on Oct 30, 2007 4:03 PM by Adrian Apthorp

    websale example: problems with RemindActor timer action

    Adrian Apthorp Newbie

      I've just installed the 3.2.2 suite having not looked at JBPM for a while.

      Having got the websale demo working I'm now experiencing the following error:

      UnsupportedClassVersionError: Bad version number in .class file

      which results in

      JbpmJobExector:<my ip address>:1 leaves cyberspace

      I think this has something to do with the RemindActor timer action, as I redeployed (no change made) this file immediately before I got the error. everything else seems to work apart from the timer.

      Any ideas? I'm assuming this is a JDK / JRE version problem. I initially was seeing version problems with JDK 1.4.2 and upgraded to 1.5.0 13. Do I need to go to 1.6.0 1? This is the JRE that the Jbpm eclipse download seems to be using.

      thanks

      Adrian