0 Replies Latest reply on Nov 16, 2007 9:48 AM by Frank

    Help! Cannot get JBpm Console working on JBoss

    Frank Newbie

      Hi all!
      I need to deploy the jbpm-console.war (Jbpm version jbpm-3.1.3) to an existing instance of JBoss 4.0.2.

      I have copied the file jbpm-console.war in the "deploy" folder, as well I have copied the jbpm-ds.xml file which contains the datasource information.
      Finally I copied the jbpm "libs" in the lib folder of the application server.

      Now I have restarted JBoss but I get the following start-up error:

      11:16:43,859 WARN [JDBCExceptionReporter] SQL Error: -22, SQLState: S0002
      11:16:43,859 ERROR [JDBCExceptionReporter] Table doesn't exist in statement [select top ? job0_.ID_ as ID1_26_, job0_.VERSION_ as VERSION3_26_, job0_.DUEDATE_ as DUEDATE4_26_, job0_.PROCESSINSTANCE_ as PROCESSI5_26_, job0_.TOKEN_ as TOKEN6_26_, job0_.TASKINSTANCE_ as TASKINST7_26_, job0_.ISSUSPENDED_ as ISSUSPEN8_26_,
      job0_.ISEXCLUSIVE_ as ISEXCLUS9_26_, job0_.LOCKOWNER_ as LOCKOWNER10_26_, job0_.
      LOCKTIME_ as LOCKTIME11_26_, job0_.EXCEPTION_ as EXCEPTION12_26_, job0_.RETRIES_
       as RETRIES13_26_, job0_.NAME_ as NAME14_26_, job0_.REPEAT_ as REPEAT15_26_, job
      0_.TRANSITIONNAME_ as TRANSIT16_26_, job0_.ACTION_ as ACTION17_26_, job0_.GRAPHE
      LEMENTTYPE_ as GRAPHEL18_26_, job0_.GRAPHELEMENT_ as GRAPHEL19_26_, job0_.NODE_
      as NODE20_26_, job0_.CLASS_ as CLASS2_26_ from JBPM_JOB job0_ where (job0_.LOCKO
      WNER_ is null or job0_.LOCKOWNER_=?) and job0_.RETRIES_>0 and job0_.DUEDATE_<=?
      and job0_.ISSUSPENDED_<>1 order by job0_.DUEDATE_ asc]
      11:16:43,859 ERROR [JobSession] org.hibernate.exception.SQLGrammarException: could not execute query
       11:16:43,859 ERROR [JobExecutorThread] exception in job executor thread. waiting
       5000 milliseconds
      org.jbpm.JbpmException: couldn't get acquirable jobs
       at org.jbpm.db.JobSession.getFirstAcquirableJob(JobSession.java:44)
       at org.jbpm.job.executor.JobExecutorThread.acquireJobs(JobExecutorThread
      .java:114)
       at org.jbpm.job.executor.JobExecutorThread.run(JobExecutorThread.java:58
      )
      Caused by: org.hibernate.exception.SQLGrammarException: could not execute query
       at org.hibernate.exception.SQLStateConverter.convert(SQLStateConverter.j
      ava:67)
       at org.hibernate.exception.JDBCExceptionHelper.convert(JDBCExceptionHelp
      er.java:43)
       at org.hibernate.loader.Loader.doList(Loader.java:2147)
       at org.hibernate.loader.Loader.listIgnoreQueryCache(Loader.java:2028)
       at org.hibernate.loader.Loader.list(Loader.java:2023)
       at org.hibernate.loader.hql.QueryLoader.list(QueryLoader.java:393)
       at org.hibernate.hql.ast.QueryTranslatorImpl.list(QueryTranslatorImpl.ja
      va:338)
       at org.hibernate.engine.query.HQLQueryPlan.performList(HQLQueryPlan.java
      :172)
       at org.hibernate.impl.SessionImpl.list(SessionImpl.java:1121)
       at org.hibernate.impl.QueryImpl.list(QueryImpl.java:79)
       at org.hibernate.impl.AbstractQueryImpl.uniqueResult(AbstractQueryImpl.j
      ava:780)
       at org.jbpm.db.JobSession.getFirstAcquirableJob(JobSession.java:40)
       ... 2 more


      Anybody managed to fix this problem....?

      the datasource file is this,

      <?xml version="1.0" encoding="UTF-8"?>
      
      <datasources>
      
       <local-tx-datasource>
       <jndi-name>JbpmDS</jndi-name>
       <connection-url>jdbc:hsqldb:${jboss.server.data.dir}${/}hypersonic${/}jbpmDB</connection-url>
       <driver-class>org.hsqldb.jdbcDriver</driver-class>
       <user-name>sa</user-name>
       <password></password>
       <min-pool-size>1</min-pool-size>
       <max-pool-size>5</max-pool-size>
       <idle-timeout-minutes>0</idle-timeout-minutes>
       <track-statements/>
       <!--
       <security-domain>HsqlDbRealm</security-domain>
       -->
       <prepared-statement-cache-size>32</prepared-statement-cache-size>
       <metadata><type-mapping>Hypersonic SQL</type-mapping></metadata>
       <depends>jboss:service=Hypersonic,database=jbpmDB</depends>
       </local-tx-datasource>
      
       <mbean code="org.jboss.jdbc.HypersonicDatabase"
       name="jboss:service=Hypersonic,database=jbpmDB">
       <attribute name="Database">jbpmDB</attribute>
       <attribute name="InProcessMode">true</attribute>
       </mbean>
      
      </datasources>



      but I have copied as it is from the bundled jboss-jbpm server, which by the way, works perfectly.
      Unfortunately I need to install the single jbpm components on a production JBoss server...i cannot install the whole bundle.

      Any help ?
      Thanks
      Francesco