4 Replies Latest reply on Feb 11, 2008 5:15 AM by N/A N/A

    BPEL

    N/A N/A Newbie

      Hi all,

      I'm trying to install the "hello"-BPEL example for hours now. Would be great if someone could give me some hint where the problem is. Here is what I've done so far (just followed the getting started tutorial):

      I've installed JBoss application server and jbpm-bpel (pls. see attached versions below). I can access the jBPM-web-console, could generated the database scheme - all without any problems. But when I try to deploy the "hello" example I get the following error message (stack trace) on jboss console (deployment is done with unchanged ant task "deploy.process"):

      I'm looking forward to your responses and ideas!

      17:20:46,742 INFO [DeploymentServlet] deployed process definition: HelloWorld
      17:20:46,880 ERROR [[deploymentServlet]] Servlet.service() for servlet deploymen
      tServlet threw exception
      java.lang.NullPointerException
       at org.jbpm.bpel.tools.WscompileTool.getLocation(WscompileTool.java:240)
      
       at org.jbpm.bpel.tools.WscompileTool.formatClasspath(WscompileTool.java:
      227)
       at org.jbpm.bpel.tools.WscompileTool.callWscompile(WscompileTool.java:19
      7)
       at org.jbpm.bpel.tools.WscompileTool.generateJavaMappingImpl(WscompileTo
      ol.java:156)
       at org.jbpm.bpel.tools.WscompileTool.generateJavaMapping(WscompileTool.j
      ava:143)
       at org.jbpm.bpel.tools.WebModuleBuilder.callJavaMappingTool(WebModuleBui
      lder.java:264)
       at org.jbpm.bpel.tools.WebModuleBuilder.buildModuleImpl(WebModuleBuilder
      .java:102)
       at org.jbpm.bpel.tools.WebModuleBuilder.buildModule(WebModuleBuilder.jav
      a:84)
       at org.jbpm.bpel.web.DeploymentServlet.deployWebModule(DeploymentServlet
      .java:205)
       at org.jbpm.bpel.web.DeploymentServlet.doPost(DeploymentServlet.java:99)
      
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
      icationFilterChain.java:290)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
      ilterChain.java:206)
       at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFi
      lter.java:96)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Appl
      icationFilterChain.java:235)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
      ilterChain.java:206)
       at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperV
      alve.java:230)
       at org.apache.catalina.core.StandardContextValve.invoke(StandardContextV
      alve.java:175)
       at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(Securit
      yAssociationValve.java:179)
       at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValv
      e.java:84)
       at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.j
      ava:127)
       at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.j
      ava:102)
       at org.jboss.web.tomcat.service.jca.CachedConnectionValve.invoke(CachedC
      onnectionValve.java:157)
       at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineVal
      ve.java:109)
       at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.jav
      a:262)
       at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java
      :844)
       at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.proce
      ss(Http11Protocol.java:583)
       at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:44
      6)
       at java.lang.Thread.run(Thread.java:619)
      
      


      I'm using currently using:
      - JBoss 4.2.2GA
      - jbpm-bpel1.1GA