2 Replies Latest reply on Dec 15, 2008 6:55 AM by Sara Rodríguez Dorrego

    Problem with WS in jBPM

    Sara Rodríguez Dorrego Novice

      Hello!!

      I've a problem. Some moths ago, I made a prototype using WS, Jboss 4.0.5 and Jbpm 3.2.2. It worked!!! It consisted in that an app (that resides in Jboss 4.0.5) invoked to a WS that was in jbpm 3.2.2.

      Now, I want to do the same, but it doesn't work. I don't know why don't work. The main reason that I could imaginate is that I changed the jdk version. Now I'm using jdk 6.0 instead jdk 1.5.

      The problem is:

      - The WS seems that is desployed fine because I can access to the wsdl file in :

      http://192.168.0.130:18080/Requirements-JbpmWebServices/JbpmWS?wsdl


      But if I put into the navegator --->
      http://192.168.0.130:18080/Requirements-JbpmWebServices/JbpmWS

      It fails and the following error is shown:

      org.jboss.util.NotImplementedException: HTTP GET not supported
       org.jboss.ws.server.ServiceEndpointServlet.doGet(ServiceEndpointServlet.java:95)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:697)
       javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
       org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
      


      On the other hand, when I run my app and I try to call to my simply web service this is what occurs:

      A) At client side

      Retrieving the port from the following service: com.ideit.modules.cmmi.jbpm.requirements.ws.JbpmWS_Service@1362012
      Invoking the sayHello operation on the port.
      Exception in thread "main" javax.xml.ws.WebServiceException: No Content-type in the header!
       at com.sun.xml.ws.transport.http.client.HttpTransportPipe.process(HttpTransportPipe.java:143)
       at com.sun.xml.ws.transport.http.client.HttpTransportPipe.processRequest(HttpTransportPipe.java:74)
       at com.sun.xml.ws.api.pipe.Fiber.__doRun(Fiber.java:559)
       at com.sun.xml.ws.api.pipe.Fiber._doRun(Fiber.java:518)
       at com.sun.xml.ws.api.pipe.Fiber.doRun(Fiber.java:503)
       at com.sun.xml.ws.api.pipe.Fiber.runSync(Fiber.java:400)
       at com.sun.xml.ws.client.Stub.process(Stub.java:235)
       at com.sun.xml.ws.client.sei.SEIStub.doProcess(SEIStub.java:120)
       at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:230)
       at com.sun.xml.ws.client.sei.SyncMethodHandler.invoke(SyncMethodHandler.java:210)
       at com.sun.xml.ws.client.sei.SEIStub.invoke(SEIStub.java:103)
       at $Proxy25.hola(Unknown Source)
       at client.JbpmWSClient.main(JbpmWSClient.java:22)


      B) At server side

      12:43:17,203 ERROR [[JbpmWS]] Servlet.service() for servlet JbpmWS threw exception
      java.lang.NoClassDefFoundError: Could not initialize class org.jboss.ws.soap.MessageFactoryImpl
       at org.jboss.ws.server.ServiceEndpoint.handleRequest(ServiceEndpoint.java:211)
       at org.jboss.ws.server.ServiceEndpointServlet.doPost(ServiceEndpointServlet.java:120)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
       at javax.servlet.http.HttpServlet.service(HttpServlet.java:810)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
       at org.jboss.web.tomcat.filters.ReplyHeaderFilter.doFilter(ReplyHeaderFilter.java:96)
       at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
       at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
       at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
       at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
       at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:175)
       at org.jboss.web.tomcat.security.JaccContextValve.invoke(JaccContextValve.java:74)
       at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
       at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
       at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
       at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
       at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
       at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
       at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
       at org.apache.tomcat.util.net.MasterSlaveWorkerThread.run(MasterSlaveWorkerThread.java:112)
       at java.lang.Thread.run(Thread.java:619)
      


      Any ideas???? I suspect that is a problem with jdk or loader libraries, but .. I don't know how to fix it because I have the jbossws-client.jar that contains org.jboss.ws.soap.MessageFactoryImpl in client folder of jboss.


      Thanks!!!