8 Replies Latest reply on Jan 14, 2009 12:53 PM by Ronald van Kuijk

    Can't get Generate Form to work at all?

    John Wells Newbie

      Hi guys.

      I'm using jbpm-3.3.0.GA and have designed a few test processes. However, nothing I seem to do will make "Generate Form" pick up the variables I've defined in the controller. I've tried everything I can find in the forums...it seems I have similar problems to some (see this thread: http://www.jboss.com/index.html?module=bb&op=viewtopic&p=4127498#4127498) but going through and pressing enter as described doesn't fix it.

      Here are three screenshots. In the first, note the mapped names don't show up, as described in the aforementioned thread.
      [img]http://bayimg.com/AamMpAABO[/img]
      In the second, I've gone through and pressed enter in each mapped name field...so now they appear to be done properly.
      [img]http://bayimg.com/BaMmbaABO[/img]
      In the third, you see the result of pressing "Generate Form..." on the Details tab. No variables :(
      [img]http://bayimg.com/bAmmIAAbo[/img]
      Am I doing something wrong or misunderstanding something? Is there anything I can provide that might help debug this issue?

      Thanks,
      jbwiv[/img]

        • 1. Re: Can't get Generate Form to work at all?
          John Wells Newbie

          Seems the image tag in my post isn't working. Here's clickable urls to the images:

          http://bayimg.com/AamMpAABO
          http://bayimg.com/BaMmbaABO
          http://bayimg.com/bAmmIAAbo

          • 2. Re: Can't get Generate Form to work at all?
            John Wells Newbie

            And here's the generated code. Note my task name has no spaces:

            <?xml version="1.0" encoding="UTF-8"?>
            
            <process-definition
             xmlns="urn:jbpm.org:jpdl-3.2"
             name="simple">
            
            
             <swimlane name="Submitter">
             <assignment expression="group(pr_submitter)"></assignment>
             </swimlane>
            
             <swimlane name="PR Approver">
             <assignment expression="group(pr_approver)"></assignment>
             </swimlane>
            
             <swimlane name="Vice President">
             <assignment expression="group(vice_president)"></assignment>
             </swimlane>
            
             <swimlane name="Accounting">
             <assignment expression="group(accounting)"></assignment>
             </swimlane>
            
             <swimlane name="Purchasing">
             <assignment expression="group(purchasing)"></assignment>
             </swimlane>
            
            
             <start-state name="Start">
             <task name="Submit_PR" swimlane="Submitter">
             <controller>
             <variable access="read,write,required" name="Location" mapped-name="location"></variable>
             <variable access="read,write,required" name="PR Number" mapped-name="prNumber"></variable>
             <variable access="read,write,required" name="Contact Info" mapped-name="contactInfo"></variable>
             <variable access="read,write,required" name="Date Needed" mapped-name="dateNeeded"></variable>
             <variable access="read,write,required" name="GL Account" mapped-name="glAccount"></variable>
             <variable access="read,write,required" name="GL Department" mapped-name="glDept"></variable>
             <variable access="read,write,required" name="Purchase Type" mapped-name="purchaseType"></variable>
             <variable access="read,write,required" name="Manager" mapped-name="manager"></variable>
             <variable access="read,write,required" name="PO Assigned" mapped-name="poAssigned"></variable>
             <variable access="read,write,required" name="Buyer" mapped-name="buyer"></variable>
             <variable access="read,write,required" name="Supplier" mapped-name="supplier"></variable>
             <variable access="read,write,required" name="Remarks" mapped-name="remarks"></variable>
             </controller>
             </task>
             <transition to="Manager Approval"></transition>
             </start-state>
            
            
             <task-node name="VP Approval">
             <transition to="Accounting Approval" name="Yes"></transition>
             <transition to="Send Rejection Notice" name="No"></transition>
             </task-node>
            
             <task-node name="Accounting Approval">
             <transition to="Route to purchasing" name="Yes"></transition>
             <transition to="Send Rejection Notice" name="No"></transition>
             </task-node>
            
             <decision name="Is Amount greater than 500?">
             <transition to="VP Approval" name="Yes"></transition>
             <transition to="Accounting Approval" name="No"></transition>
             </decision>
            
             <task-node name="Route to purchasing">
             <transition to="Completed"></transition>
             </task-node>
            
             <decision name="Manager Approval">
             <transition to="Is Amount greater than 500?" name="Yes"></transition>
             </decision>
            
             <task-node name="Send Rejection Notice">
             <transition to="Start"></transition>
             </task-node>
            
            
             <end-state name="Completed"></end-state>
            
            
            </process-definition>


            • 3. Re: Can't get Generate Form to work at all?
              John Wells Newbie

              Help...anyone? I tried to create a much simpler process, and the problem persisted there as well. How can one get around this?

              Thanks,
              jbwiv

              • 4. Re: Can't get Generate Form to work at all?
                John Wells Newbie

                Is this something a Redhat support contract would get an answer on?

                • 5. Re: Can't get Generate Form to work at all?
                  Ronald van Kuijk Master

                  might be, or someone in the forum that is willing to try to reproduce.... one question... isn't the form by generated and this page just empty?

                  • 6. Re: Can't get Generate Form to work at all?
                    John Wells Newbie

                    Hello kukeltje,

                    I appreciate your response. However, would you mind restating your question? I'm not sure I understand what you're asking.

                    Thanks,
                    jbwiv

                    • 7. Re: Can't get Generate Form to work at all?
                      Ronald van Kuijk Master

                       

                      Is this something a Redhat support contract would get an answer on?


                      might be, or someone in the forum that is willing to try to reproduce

                      [quoteHelp...anyone? I tried to create a much simpler process, and the problem persisted there as well. How can one get around this?

                      • 8. Re: Can't get Generate Form to work at all?
                        Ronald van Kuijk Master

                        Sorry, wrong quoting...

                        Is this something a Redhat support contract would get an answer on?


                        might be, or someone in the forum that is willing to try to reproduce

                        Help...anyone? I tried to create a much simpler process, and the problem persisted there as well. How can one get around this?


                        Can it be that while this GPD page is empty, the form is still generated as a file?