4 Replies Latest reply on Aug 6, 2008 9:32 AM by stella

    sortBy attribute indefined

    stella Newbie

      I´m new to jsf and richfaces, I'm using rich:column tag in rich:dataTable, and I want to use the sortBy attribute, but I always get this error :

      org.apache.jasper.JasperException: /pages/InfoBts.jsp(46,13) sortBy attribute is not valid with the specified TLD.

      I´m using jsf- 1.2, richfaces-3.1.6.GA.
      Everything goes well without this attribute, any help?

        • 1. Re: sortBy attribute indefined
          sammy Jenkis Newbie

          Column sorting is only available in Richfaces 3.2.x.

          • 2. Re: sortBy attribute indefined
            stella Newbie

            Thanks for your answer but I'm working with eclipse jsf framework, so I hava a jsf Proyect with JSF 1.2 and when I tried with richfaces-3.2.1.GA.zip, I get this error when Tomcat-6 is inicializing:

            java.lang.ClassNotFoundException: org.ajax4jsf.application.AjaxStateManager$SynchronizedStateHolder

            • 3. Re: sortBy attribute indefined
              sammy Jenkis Newbie

              Is it possible that more than one version of Richfaces is on your classpath when that happens?

              • 4. Re: sortBy attribute indefined
                stella Newbie

                I created a new jsf-1.2 proyect in a new workspace, and then I added the richfaces-3.2.1.GA libraries (3) in the lib directory, and when I run Tomcat 6.0 from eclipse I got this new error

                java.lang.ClassNotFoundException: com.sun.faces.config.ConfigureListener
                at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1360)
                at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1206)
                at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:3786)
                at org.apache.catalina.core.StandardContext.start(StandardContext.java:4350)
                at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
                at org.apache.catalina.core.StandardHost.start(StandardHost.java:719)
                at org.apache.catalina.core.ContainerBase.start(ContainerBase.java:1045)
                at org.apache.catalina.core.StandardEngine.start(StandardEngine.java:443)
                at org.apache.catalina.core.StandardService.start(StandardService.java:516)
                at org.apache.catalina.core.StandardServer.start(StandardServer.java:710)
                at org.apache.catalina.startup.Catalina.start(Catalina.java:578)
                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
                at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
                at java.lang.reflect.Method.invoke(Unknown Source)
                at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:288)
                at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:413)
                06-ago-2008 9:41:15 org.apache.catalina.core.StandardContext listenerStart

                My java classpath contains this libs :

                common-annotations.jar
                commons-beanutils.jar
                commons-collections.jar
                commons-digester.jar
                commons-logging.jar
                jsf-tlds.jar
                jstl.jar
                standard.jar
                richfaces-ui-3.2.1.GA.jar
                richfaces-api-3.2.1.GA.jar
                richfaces-impl-3.2.1.GA.jar

                The last 3 I putted by hand and the others was the eclipse Europa jsf framework that putted there.
                I tried to add this ones :
                jsf-api.jar
                jsf-impl.jar
                But the same error appeared and also this new one :
                java.lang.NoClassDefFoundError: javax/faces/component/ActionSource2
                at java.lang.ClassLoader.defineClass1(Native Method)
                at java.lang.ClassLoader.defineClass(Unknown Source)
                at java.security.SecureClassLoader.defineClass(Unknown Source)

                Perhaps is a bug in the eclipse Europa framework.
                I have to try what happen running tomcat from the outside of eclipse.
                Thanks for your help anyway