4 Replies Latest reply on Nov 27, 2009 7:07 AM by Dejan Mratinkovic

    jbpm-console

    Suneet Shah Newbie

      Hello

      I have just installed jbpm 4.2 on tomcat using the ant scripts included with the download. However, I am not able to log into the jbpm-console. I tried the users listed in the getting started docs, but non of those work.

      What should i be using to login?

      How can I create new users?

      Thanks

        • 1. Re: jbpm-console
          Sebastian Schneider Master

          Have you set up the sample identities? You can create new users programmatically using the IdentityService or you can just add them in the users' table in the database. In this case don't forget to create a group membership for them or you won't be able to login.

          http://docs.jboss.com/jbpm/v4/javadocs/org/jbpm/api/IdentityService.html

          • 2. Re: jbpm-console
            Dejan Mratinkovic Newbie

             

            "sebastian.s" wrote:
            You can create new users programmatically using the IdentityService or you can just add them in the users' table in the database.

            I got it working easy, and it was easy to include it to my custom app (ear).

            But, can it use custom IdentitySession?

            I have custom identity session, but jbpm console works kind of unusual. On initial log in, it ignores custom IdentitySession, and loging is possible only with users on database. But, once logged in, all actions trigger the custom class, and my custom behavior.

            Is this expected behaviour? Was jbpm-console intended to be extended with custom user management the same way jbpm itself is?

            Thanks.


            • 3. Re: jbpm-console
              Sebastian Schneider Master

              I have no clue how it is done in JBoss because I am using Tomcat. The Tomcat demo setup (jBPM-4.1) has this lines in the server.xml to reference the jBPM users' database. I don't know how JbpmConsoleRealm is implemented.

              
               <Engine name="Catalina" defaultHost="localhost">
              
               <Host name="localhost" appBase="webapps" unpackWARs="true"
               autoDeploy="true" xmlValidation="false" xmlNamespaceAware="false">
              
               <!--
               Current workaround for using the JBPM identity tables on Tomcat.
               Setting the Realm on the context with path /jbpm-console did not seem
               to work. Note that this workaround means that the cmplete localhost
               domain will use this realm !
               -->
               <Realm className="org.jbpm.integration.tomcat6.JbpmConsoleRealm"
               driverName="org.hsqldb.jdbcDriver"
               connectionUrl="jdbc:hsqldb:hsql://localhost:1701"
               connectionName="sa"
               connectionPassword="" />
              
               </Host>
               </Engine>
              


              It could be that the console does not use the custom IdentitySession since the BPM-console is not jused used exclusively for jBPM. Maybe you should ask about this in the BPM-Console forum.

              P.S.: Please quote me correctly next time. :)

              • 4. Re: jbpm-console
                Dejan Mratinkovic Newbie

                 

                "sebastian.s" wrote:
                P.S.: Please quote me correctly next time. :)


                Is this good enogh? Sorry for previous post, this forum has very nice feature - you can not edit or remove post once you have submitted it. So, if you submit something by mistake, no way to fix it.

                "sebastian.s" wrote:

                It could be that the console does not use the custom IdentitySession since the BPM-console is not jused used exclusively for jBPM.


                This probably is the cause. Thank for the answer. Too bad they did not use standard way of log in to application (like in gwt-console-server-jbpm where it is easy to customize), but they own approach, which makes customization hard to people not familiar with gwt.