10 Replies Latest reply on Apr 10, 2010 10:04 AM by Vincen Collins

    Console: host not found error

    Rogelio Di Pasquale Newbie

      Hi

      I'm developing processes on JBPM 4.1 using JBoss 5.0.0.GA; everything runs fine, but when I want to access the console from outside the development net, I can only view the list of tasks. When I click "View", the frame doesn't show the .ftl file, but a "hots not found", or "host does not respond" notice.

      If I check the properties of the frame source, I see that it is looking for

      http://windowsServerName:8080/gwt-console-server/rs/form/task/2/render


      when it should be

      http://publicIP:public port/gwt-console-server/rs/form/task/2/render
      

      As I thought it was JBoss using hard [windowsServerName], I changed the Connector Protocol in the file server.xml from

      <Connector protocol="HTTP/1.1" port="8080" address="${jboss.bind.address}"


      to

      <Connector protocol="HTTP/1.1" port="8080" address="[publicIP]"


      but nothing changed.


      My setup is:
      Windows 2003 server running JBoss 5.0.0.GA, JBPM 4.1
      JBoss listens to local port 8080
      When I acces from Internet, I have the router translating public IP/public port to localIP:8080, and it works fine with jmx console, web console and even gwt console main menu - not ftl files frame.



      Is this JBoss configuration problem, or gwt-console config problem? Did anybody have this issue?

      Thanks,
      Roger

        • 1. Re: Console: host not found error
          Ronald van Kuijk Master

          it is a console config issue. Please search the forum and the jira.

          • 2. Re: Console: host not found error
            Rogelio Di Pasquale Newbie

            Hi, all

            Thanks for your answer, Ronald.

            Though I've been searching for information on this fact for a few weeks, I had not reached an answer until now. I accept I'm not really used to JIRAs yet.

            After Ronalds response, I started browsing all JIRA issues (not only Console), and found this one in JBPM, issue 2562: "Hard-coded host and port for Tomcat".

            You can find https://jira.jboss.org/jira/browse/JBPM-2562

            With what Tom comments in that JIRA, I found the JBPM server configuration file at: {JBOSS_HOME}\server\default\deploy\jbpm\jbpm-service.sar\jbpm-service-jboss-beans.xml

            In that file, I changed this code:

            <bean name="org.jbpm:service=ServerConfig"
             class="org.jbpm.integration.jboss5.mgmt.ServerConfig">
             <property name="mbeanServer"><inject bean="JMXKernel" property="mbeanServer"/></property>
             <property name="webServiceHost">${jboss.bind.address}</property>
             </bean>
            

            to this one (I'm changing webServiceHost property, and adding webServicePort):
            <bean name="org.jbpm:service=ServerConfig"
             class="org.jbpm.integration.jboss5.mgmt.ServerConfig">
             <property name="mbeanServer"><inject bean="JMXKernel" property="mbeanServer"/></property>
             <property name="webServiceHost">publicIP</property>
             <property name="webServicePort">publicPort</property>
             </bean>
            


            And now it is working correctly from outside the router/firewall.

            I didn't try it yet, but I suppose that now I will have the previous problem when trying to access this files from inside the network, if that network can't resolv the public IP.



            • 3. Re: Console: host not found error
              Joram Barrez Master
              Since jbpm 4.2, the host and port are set by importing/changing the jbpm.console.cfg.xml file in your jbpm config.
              • 4. Re: Console: host not found error
                carlos mauricio jaramillo henao Newbie
                Hi all

                I  had the same problem as Rogelio. My process I have  published in a machine and when I try to click on "View" for a task  (with file extension. Jsp) I do not show it. You can only see from the  client machine is mounted around the jBPM. I reviewed the 2562 issue  that said Rogelio but I could not come up with the solution. Install the version 4.3  but the error remains the same.

                The bug is fixed in that  version would come forth??
                The version 4.4 will be  available when???

                I'm using Tomcat6.0 with  jBPM-4.2 and postgres. Any ideas how I can fix  this problem.

                Thanks
                • 5. Re: Console: host not found error
                  Maciej Swiderski Master

                  Hi,

                   

                  I encountered similar issue and the solution was modifying jbpm.console.cfg.xml that is part of jbpm.jar. Please note that this was solution for 4.3.

                   

                  Cheers,

                  Maciej

                  • 6. Re: Console: host not found error
                    carlos mauricio jaramillo henao Newbie

                    Thanks for the response. I change file  jbpm.console.cfg.xml that is in the path (JBPM_HOME)/src/jbpm.console.cfg.xml

                    In the project
                    examples I added  the tag <import resource="jbpm.console.cfg.xml" /> in the file  jbpm.cfg.xml

                     

                    jbpm.cfg.xml

                    <jbpm-configuration>
                     
                    <import  resource="jbpm.default.cfg.xml" />
                     
                    <import  resource="jbpm.businesscalendar.cfg.xml" />
                     
                    <import  resource="jbpm.tx.hibernate.cfg.xml" />
                     
                    <import  resource="jbpm.jpdl.cfg.xml" />
                     
                    <import  resource="jbpm.bpmn.cfg.xml" />
                     
                    <import  resource="jbpm.identity.cfg.xml" />
                     
                    <import  resource="jbpm.console.cfg.xml" />
                      <import  resource="jbpm.mail.templates.examples.xml" />
                    </  jbpm-configuration>

                     

                    jbpm.console.cfg.xml

                    <jbpm-configuration>

                      <process-engine-context>
                        <string name="jbpm.console.server.host" value="10.1.1.175" /> //IP the server
                        <string name="jbpm.console.server.port" value="8080" />
                      </process-engine-context>

                    </jbpm-configuration>

                     

                    When I connect from another  machine by the browser I can not see the tasks

                     

                    Thanks

                    • 7. Re: Console: host not found error
                      Maciej Swiderski Master

                      Hi

                       

                      I am not sure that file that you modified is loaded by jBPM runtime. I think that jbpm.default.cfg.xml file already contains import statement for console configuration (which is inside jbpm.jar).

                       

                      You could try to verify that using REST interface for console. Go to following URLs on your machine to get list of tasks and then render one of them to get the form:

                      - list tasks - http://10.1.1.175:8080/gwt-console-server/rs/tasks/{username} - replace username with actual name of the user assigned to a task

                      this should return list of tasks with ids

                       

                      - render a form for selected task by its id - http://10.1.1.175:8080/gwt-console-server/rs/form/task/{id}/render

                       

                      Once you get the form rendered you could view page source where you should get information about the console host. That should help you to verify that your modified configuration is loaded properly.

                       

                      Cheers,

                      Maciej

                      • 8. Re: Console: host not found error
                        carlos mauricio jaramillo henao Newbie

                        Maciej thanks for your  help.

                         

                        I've been able to solve  the problem I had to reinstall jBPM-4.3 and then edit the file in  jbpm.console.cfg.xml that I jbpm.jar poor in firefox and it works fine,  the problem now is that in Internet Explorer form does not load, you  know why can this be?

                        For now present my  project only on firefox

                         

                        Thanks

                        • 9. Re: Console: host not found error
                          Maciej Swiderski Master
                          Have you tried to clean up browser cache?!
                          • 10. Re: Console: host not found error
                            Vincen Collins Newbie

                            I am having the same issue in Internet Explorer.  The /gwt-console-server/rs/form/task/{id}/render request is successful and the correct html is in the response but the task form is not getting displayed.  Everything works correctly in firefox.  I have cleared the cache but the forms are still not displayed in Internet Explorer.  Any help would be appreciated.  Thanks!