4 Replies Latest reply on Mar 25, 2006 11:55 AM by Stacey Vetzal

    trouble with create.db ant task

    Stacey Vetzal Newbie

      Hi Folks,

      I can't get the create.db ant task working... I'm checked out from the current CVS head, and using:

      ant -f build.deploy.xml create.db

      emits the following error:

      ----< lots of ant output deleted >----
      [jbpmschema] alter table JBPM_VARIABLEINSTANCE add constraint FK_BYTEINST_ARRAY foreign key (BYTEARRAYVALUE_) references JBPM_BYTEARRAY
      [loadidentities] loading identities from /home/steve/Eclipse Workspaces/workspace-jboss/jbpm.3/src/resources/hsqldb/identity.db.xml ...

      BUILD FAILED
      /home/steve/Eclipse Workspaces/workspace-jboss/jbpm.3/build.deploy.xml:50: org.hibernate.HibernateException: Errors in named queries: GraphSession.findAllProcessDefinitionVersions, SchedulerSession.findTimersByName, MessagingSession.resumeMessagesForToken, GraphSession.selectLogsForTokens, GraphSession.findTokensForProcessInstance, TaskMgmtSession.findTaskInstancesByIds, MessagingSession.findMessages, SchedulerSession.findSuspendedTimers, LoggingSession.findLogsByToken, MessagingSession.suspendMessagesForToken, TaskMgmtSession.findTaskInstancesByActorId, SchedulerSession.resumeTimersForToken, TaskMgmtSession.findPooledTaskInstancesByActorId, TaskMgmtSession.findTaskInstancesByTokenId, SchedulerSession.suspendTimersForToken, GraphSession.findAllProcessInstancesForADefinition, GraphSession.findProcessDefinitionByNameAndVersion, MessagingSession.findErrorMessages, SchedulerSession.deleteTimersForProcessInstance, TaskMgmtSession.findPooledTaskInstancesByActorIds, SchedulerSession.findFailedTimers, GraphSession.findLatestProcessDefinitionQuery, SchedulerSession.findTimersByDueDate, TaskMgmtSession.findTaskInstancesByActorIds, GraphSession.findAllProcessDefinitions

      I must be missing something simple... I just haven't been able to figure it out.

        • 1. Re: trouble with create.db ant task
          Stacey Vetzal Newbie

          Oh, here's a copy of my build.properties:

          # jbpm.version only used for creating javadocs and the distribution package
          jbpm.version=3.1

          # ant.home is only used in the ant.install.libs target for copying the junit and clover libs
          ant.home=/usr/share/ant-core

          # jbpm.home is only to allow build scripts to open the browser with the html test results
          jbpm.home=/home/steve/ew/workspace-jboss/jbpm.3

          # jboss config proper only used for deployment
          jboss.home=/home/steve/sw/clean/jboss-4.0.3SP1
          jboss.version=4.0.x
          jboss.source.configuration=default

          # for creating the distribution
          jbpm.gpd.version=3.0.4


          I have a freshly unpacked version of jboss at ${jboss.home} and the jbpm source checkout is at ${jbpm.home}.


          One thing I was noting, this file is checked into CVS with hard-coded paths (!), IMHO it would be much better to provide a build.properties.sample and add build.properties to .cvsignore so developers don't fight each other on paths.

          • 2. Re: trouble with create.db ant task
            Tom Baeyens Master

            it's the jboss version, i think. or combination of hibernate and other libs.

            try using a clean jboss-4.0.3

            • 3. Re: trouble with create.db ant task
              Stacey Vetzal Newbie

              Sorry, didn't realize you meant 4.0.3 literally earlier :)

              I tried with 4.0.3 though, and it still doesn't pass that point, same symptoms.

              • 4. Re: trouble with create.db ant task
                Stacey Vetzal Newbie

                The above errors were caused by an incomplete Ant installation. I accidentally had another version of Ant on my path that was conflicting.

                Thanks!