4 Replies Latest reply on Jun 12, 2007 11:53 AM by Matthew Sandoz

    building and testing sources

    Matthew Sandoz Newbie

      hi - ive read these pages and used them to start off my development:

      http://wiki.jboss.org/wiki/Wiki.jsp?page=JbpmBuildingTheSources
      http://wiki.jboss.org/wiki/Wiki.jsp?page=Jbpm3DevelopDesignerInEclipse

      in the directions it says to ensure WST is installed. one thing i found was that WST has lots of dependencies - that made me nervous as i want to stick to the descriptions as much as possible and not introduce any wildcards - i downloaded them from the callisto site.

      i checked out the sources (from HEAD) today and configured the build properties and initialized my local repository. here is what i ran into:

      1. from the command line the test.jpdl worked fine except for what looks like a javadoc error:

      [javadoc] javadoc: error - Error while reading file C:\cvsgrab-2.3\JBPM\jbpm.3\jpdl\jar\src\main\java\package.html

      2. i get an error in the build.jpdl target also -
      Cannot find D:\Documents and Settings\sandozm/jbpm/repository/docbook-support/support.xml


      i then fired up eclipse.
      i set the JBPM_REPO classpath variable to my repository per the build's readme.html.
      I imported (couldnt use directly cvs - the firewall guys are going to open it up later in the week) into the workspace starting at directory ...\JBPM\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.ui project.

      per Jbpm3DevelopDesignerInEclipse i was going to run the project but it seems to be full of dependencies on the other projects - such as jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.core. also i couldnt find the icons it seems they are under another project in the tree.

      i then tried loading several of the other projects and they mostly loaded up into the workspace fine.

      still, the package org.jbpm.ui seems especially "angry" :-O and complains alot - is this package being refactored out right now? i omit it and the project's errors go away!

      now when i run...run as...eclipse application, eclipse comes up and i can create a jbpm project...but it has no connectors or icons...

      is this just me coming into the middle of a bunch of changes or is there more i need to do to get the plugin running as an eclipse app? or should i go about it another way?


        • 1. Re: building and testing sources
          Matthew Sandoz Newbie

          ah part of the build process was causing the docbook error - not the build process's fault - just reflecting my lack of access to cvs repository :)

          im working outside the work network now which has access to the cvs repository. the process is working much better but the project still seems to not work in eclipse as before mentioned...

          • 2. Re: building and testing sources
            Koen Aers Master

            The edges don't show up in existing diagrams because of a backwards incompatibility. I am working on a tool to convert old diagrams. The workaround is to do a find/replace of 'process-diagram' with 'root-container' and 'transition' with 'edge' in the gpd.xml.
            Btw. the eclipse dependencies for the plug-in are listed in the 'org.jbpm.gd.jpdl.build' project. You can download them from the Eclipse website or from the JBoss repository.

            Regards,
            Koen

            • 3. Re: building and testing sources
              Tom Baeyens Master

               

              "msandoz" wrote:
              ah part of the build process was causing the docbook error - not the build process's fault - just reflecting my lack of access to cvs repository :)

              im working outside the work network now which has access to the cvs repository. the process is working much better but the project still seems to not work in eclipse as before mentioned...


              you should be able to use the anonymous access that is configured by default.

              if you did an 'ant get.dependencies' in the build subdirectory of jbpm.3, you should be able to build without network.

              jbpm4jsf still contains a build problem... working on it

              • 4. Re: building and testing sources
                Matthew Sandoz Newbie

                i think im almost there...i am however getting this error and not sure how to fix it.

                C:\temp\jbpm.3\build\build.xml:33: The following error occurred while executing this line:
                C:\temp\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\build.xml:62: The following error occurred while executing this line
                :
                C:\temp\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\build.xml:218: Warning: Could not find file C:\temp\jbpm.3\designer\
                jpdl\org.jbpm.gd.jpdl.build\target\workspace\N.3.0.13.1\org.jbpm.gd.jpdl.feature-3.0.13.1.zip to copy.


                i have the .../workspace directory but it doesnt appear to have the N.3.0.13.1