1 Reply Latest reply on Dec 17, 2007 7:43 AM by Ronald van Kuijk

    Deployment and Build Difficulties with jBPM

    Mathias Kohler Newbie

      Hi,

      I try to build and deploy jBPM checked out from CVS (jbpm.3) and I run into some difficulties.

      1. Build error with designer
      The ant build with build/build.xml almost finishes successfully with the execption of the designer. I run into the following error:

       [java]
       [java] BUILD FAILED
       [java] C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\mainTargets.xml:25: The following error occurred while executing this line:
       [java] C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\mainTargets.xml:90: The following error occurred while executing this line:
       [java] C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\customTargets.xml:8: The following error occurred while executing this line:
       [java] C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\genericTargets.xml:133: The following error occurred while executing this line:
       [java] C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\target\workspace\assemble.org.jbpm.gd.jpdl.feature.all.xml:4: The following error
      occurred while executing this line:
       [java] C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\customTargets.xml:22: The following error occurred while executing this line:
       [java] C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\target\workspace\assemble.org.jbpm.gd.jpdl.feature.xml:54: Execute failed: java.io
      .IOException: CreateProcess: zip -r -q C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\target\workspace/N.3.1.0.SP1/org.jbpm.gd.jpdl.feature-3
      .1.0.SP1.zip eclipse/plugins/org.jbpm.gd.jpdl_3.1.1 error=2
       [java]
       [java] Total time: 32 seconds
       [java] Java Result: 13
      
      create.manifest:
      
      build-feature:
       [get] Getting: http://repository.jboss.com/licenses/JBossORG-EULA.txt
       [get] To: C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\target\temp\jboss.eula.txt
       [get] Error getting http://repository.jboss.com/licenses/JBossORG-EULA.txt to C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\target\tem
      p\jboss.eula.txt
      
      BUILD FAILED
      C:\jBPM_CVS\jbpm.3\build\build.xml:36: The following error occurred while executing this line:
      C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\build.xml:63: The following error occurred while executing this line:
      C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\build.xml:221: Warning: Could not find file C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.
      build\target\workspace\N.3.1.0.SP1\org.jbpm.gd.jpdl.feature-3.1.0.SP1.zip to copy.
      


      It seems that there is a problem building the file C:\jBPM_CVS\jbpm.3\designer\jpdl\org.jbpm.gd.jpdl.build\target\workspace/N.3.1.0.SP1/org.jbpm.gd.jpdl.feature-3
      .1.0.SP1.zip

      Any idea how to create this file?


      2. Deployment error for enterprise-ear file
      When trying to deploy the ear-file the following error occurs:

      ...
      10:03:16,320 WARN [ServiceController] Problem starting service jboss.j2ee:service=EjbModule,module=jbpm-enterprise.jar
      org.jboss.deployment.DeploymentException: type-mapping is not initialized: java:/JbpmDS was not deployed or type-mapping was not configured.
       at org.jboss.ejb.plugins.cmp.jdbc.metadata.JDBCEntityMetaData.getTypeMapping(JDBCEntityMetaData.java:1103)
       at org.jboss.ejb.plugins.cmp.jdbc.JDBCStoreManager.initStoreManager(JDBCStoreManager.java:427)
      ...


      Any Idea how to deploy this java:/JbpmDS or is there another way to solve this?

      I haven't installed a database underneath; as far as I understand jBPM should work without as well(?)

      3. Login on console fails
      Still, the deployment works in so far that I can call http://localhost:8080/jbpm-console and the login screen appears. However, when trying to login I get
      10:04:05,825 ERROR [UsersRolesLoginModule] Failed to load users/passwords/role files
      java.io.IOException: No properties file: users.properties or defaults: defaultUsers.properties found
       at org.jboss.security.auth.spi.Util.loadProperties(Util.java:315)
       at org.jboss.security.auth.spi.UsersRolesLoginModule.loadUsers(UsersRolesLoginModule.java:186)
      ...
      


      I assume this might get solved by solving one of the errors above (?) or is there something in particular to do so I can login?

      My configuration:
      I installed RedHat DevStudio CR1 (with JBoss AS 4.2.0.GA_CP01), where the eclipse part was replaced during the ant build.

      Any help or ideas how to proceed is very much appreciated!