2 Replies Latest reply on Nov 28, 2008 6:16 AM by Peter Großmann

    deploy problem

    Peter Großmann Newbie

      Hi i have a problem deploying a simple process... some hours ago it worked =( i think it depends on any jar file which is on the wrong place or something like that, any ideas?


      String op =
      "<?xml version=\"1.0\" encoding=\"UTF-8\"?>" +
      "<process-definition xmlns=\"urn:jbpm.org:jpdl-3.2\"" +
      " name=\"UseTextoutput\">" +
      " <start-state name=\"s1\">" +
      " <transition to=\"s2\">" +
      " </start-state>" +
      " <end-state name=\"s2\"></end-state>" +
      "</process-definition>";
      jbpmContext.deployProcessDefinition(ProcessDefinition.parseXmlString(op));



      leads to->



      13:14:48,007 ERROR [STDERR] Caused by: org.jbpm.util.XmlException: couldn't parse xml

      13:14:48,007 ERROR [STDERR] at org.jbpm.util.XmlUtil.parseXmlInputStream(XmlUtil.java:68)

      13:14:48,007 ERROR [STDERR] at org.jbpm.graph.node.NodeTypes.initialiseNodeTypes(NodeTypes.java:65)

      13:14:48,007 ERROR [STDERR] at org.jbpm.graph.node.NodeTypes.(NodeTypes.java:57)

      13:14:48,023 ERROR [STDERR] ... 38 more

      13:14:48,023 ERROR [STDERR] Caused by: java.lang.IllegalArgumentException: InputStream cannot be null

      13:14:48,023 ERROR [STDERR] at javax.xml.parsers.DocumentBuilder.parse(DocumentBuilder.java:120)

      13:14:48,023 ERROR [STDERR] at org.jbpm.util.XmlUtil.parseXmlInputStream(XmlUtil.java:66)

      13:14:48,023 ERROR [STDERR] ... 40 more




      after running the function first time i get the following error when i run it until i restart the server

      java.lang.NoClassDefFoundError: Could not initialize class org.jbpm.graph.action.ActionTypes