3 Replies Latest reply on Jan 29, 2009 6:13 AM by Tom Baeyens

    jbpm 4 - Term

    Bernd Ruecker Master

      HI.

      First of all one easy question: Feedback about jbpm 4 and discussions will go on in this forum, right? Or PVM?

      One thing Thomas already wrote which I lso think about: What about the term "execution"? This somehow replaced the "token", but I am not sure if that is a good idea. ProcessInstance and Token was more or less easy to explain and straight forward. Execution is not that clear...

      So I would like to see ProcessInstance and Token again, but I think that would cause a lot refactoring. What are your thoughts? Or is it decided already anyway?

      Cheers
      Bernd

        • 1. Re: jbpm 4 - Term
          Bernd Ruecker Master

          Damn forum, shortened the subject again :-/

          • 2. Re: jbpm 4 - Term
            Thomas Diesler Master

             

            So I would like to see ProcessInstance and Token again, but I think that would cause a lot refactoring. What are your thoughts? Or is it decided already anyway?
            


            This is Alpha1 - so refactoring is ok even to a large degree. The decision should be made on correctness of concept.

            The combined Execution does not sufficiently capture the conceptual difference of ProcessInstance & Token

            • 3. Re: jbpm 4 - Term
              Tom Baeyens Master

               

              "camunda" wrote:
              Feedback about jbpm 4 and discussions will go on in this forum, right? Or PVM?


              this forum is good. pvm separate forum should be deleted but i assume that it is impossible to (re)move forums.

              "camunda" wrote:
              So I would like to see ProcessInstance and Token again


              The motivation to unify process instance and token is the simple case without concurrency. When a process has no concurrency, the distinction between process instance and it's root token is artificial and confusing.

              On a PVM level, we need to have this unification. The idea was that on the jPDL level, the distinction would be made to have a JpdlProcessInstance and a JpdlExecution. But so far, (ok we're only in alpha 1) there was no need for this separation.

              Conceptually, the distinction needs to be there in case of querying.

              "camunda" wrote:
              but I think that would cause a lot refactoring. What are your thoughts? Or is it decided already anyway?


              I don't think that would cause a lot of refactoring. It's a matter of where and how this separation in the API should show up. This is a work in progress and all feedback is welcome.

              For starters: the startExecutionXxx methods should be renamed to startProcessInstanceXxx. But in the services API, I have not yet had a need for a specific ProcessInstance method. So do we introduce a ProcessInstance that extends from Execution and not adds a method ?