5 Replies Latest reply on Oct 15, 2008 9:12 AM by Stefan Poersel

    my problem the port 1098 1099

    Alex Sun Newbie

      when i start the jboss -- double click the run.bat

      the jboss console print this:

      08:46:20,168 WARN [ServiceController] Problem starting service jboss:service=Na
      ming
      java.rmi.server.ExportException: Port already in use: 1098; nested exception is:
      java.net.BindException: Address already in use: JVM_Bind


      so i change the port 1098 to 10980 on the file /server/default/conf/jboss-service.xml

      when i restart the jboss server the jboss console print this:

      08:52:21,169 ERROR [NamingService] Could not start on port 1099
      java.net.BindException: Address already in use: JVM_Bind

      and before i start the jboss i have run the fport.exe to see whether the port 1099 or 1098 have in use by other application ,but fport tell me no

      i also try the
      http://www.jboss.com/index.htmlmodule=bb&op=viewtopic&t=64248
      but it not work on my computer

      and i system is win2000 server
      jdk is jdk1.5.0_06
      jboss-4.0.3SP1

      please help me
      thanks

      alex

        • 1. Re: my problem the port 1098 1099
          Franco Apprentice


          When you reserve a range of ephemeral ports, only processes that
          specifically request a port in the reserved range can use it.

          *NOTE:* Ephemeral (short-lived) port numbers start at 1024.

          To reserve one or more ranges of ephemeral ports:

          1. Use *Regedt32.exe* to navigate to:

          *HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters*.

          2. On the *Edit* menu, *Add Value* name *ReservedPorts* as a
          *REG_MULTI_SZ Data Type*.

          3. For each range that you wish to add, type a line in the *Multi-String
          Editor* dialog, using the *FFFF-TTTT* syntax, where *FFFF* is the
          starting port of the range and *TTTT* is the ending port of the range.
          If only one port exists in the range, *FFFF* and *TTTT* are identical.

          4. Press *OK* when you have finished adding ranges.

          5. *Exit* the Registry Editor.

          • 2. Re: my problem the port 1098 1099
            Jeremy Li Newbie

            I am using Windows XP and tried the method on setting reservedports but not success.

            I found the process used the port (1098) is Outlook 2003.

            Everytime i have to close Outlook to get it work but sometime Outlook may have another port assigned that would not have the problem.

            Does anyone know if anything special with Outlook 2003 which it might override the reservedports setting?

            Or anything command to check the current reserved ports to see if I make the correct setting?

            • 3. Re: my problem the port 1098 1099
              Peter Johnson Master

              I run into this same situation with both Outlook and Norton Anti Virus at least once a month. After putting up with it for a while, I finally opened a support issue with out network services group (being in a large corp does have its benefits), but the final answer I got from them was that there was no way to change (or lock down) the port(s) that Outlook or NAV use (they checked with MS and Symantec). So the only resolution is when you run into this, reboot. Like I said, I get to do this about once a month (though I am overdue, I haven't run into this in several months). Sorry I could not offer a better solution.

              Maybe you could bring up JBoss AS before Outlook?

              • 4. Re: my problem the port 1098 1099
                SR Newbie


                I was also facing the same problem. I fixed it by changing the JNP and RMI ports in the JBoss-service.xml file.

                By default, JNP is 1099 and RMI is 1098. If you have changed your server configuration, then please make sure that both needs to different.

                Let me know if this helps you.

                Regards,
                SR

                • 5. Re: my problem the port 1098 1099
                  Stefan Poersel Newbie

                  I had the same problem on my machine. It runs with WinXP Prof and SP2. First I used

                  netstat -ao
                  to get the Process ID of the process which is using it. In my case it was
                  alg.exe
                  which is supposed to be the "Windows Firewall/Internet Connection Sharing (ICS)"-Service.

                  It turned the Microsoft built-in "Firewall" off and all is fine now.

                  Greetings
                  Stefan