1 Reply Latest reply on Jan 26, 2006 7:11 AM by jaikiran pai

    initial context lookup fails

    Jasmine Wong Newbie

      I am having problem accessing JBoss from Tomcat. We are using JBoss 4.0.3 SP1 as an application server, Apache-Tomcat 5.5.15 as a Web Server, and JDK 5.0. When I tried to submit a soap request to Tomcat, Tomcat fails at contacting the JBoss. The error message I am getting is:

      javax.naming.spi.NamingManger.getInitialContext(NamingManager.java:657)

      The program dies at:

      InitialContext initialContext=new Inititalcontext(env);

      When env is et to

      Properties env = new Properties();
      env.setProperty(?java.naming.factory.url.pkgs?, ?org.jboss.naming:org.jnp.interfaces?);
      env.setProperty(?java.naming.factory.iniital?, ?org.jnp.interfaces.NamingContextFactory?);
      env.setProperty(?java.naming.provider.url?, ?jnp://localhost:1099?);

      When I ran the same codes in JBoss 4.0.0, Apache-Tomcat 5.0.28, and JDK 4.0, it works fine.

      Are there any configurations that I need to make in JBoss 4.0.3 SP1?

      Thanks!