0 Replies Latest reply on Nov 10, 2006 5:28 AM by Andrew Gonnet

    Network is unreachable exception when "create()" called but

    Andrew Gonnet Newbie

      Hi,

      Can anyone tell me what is happening in the EJB "create()" call from a network perspective?

      I have a JBOSS app with identical clients deployed at various sites around the world, connected via an internal company WAN. All clients work except one, which gives "java.rmi.ConnectIOException: Exception creating connection to: -.--.---.---; nested exception is: java.net.SocketException: Network is unreachable: connect" (full details below) when "create( )" is called, i.e. the JNDI lookup is ok (well, no exceptions) but "create()" isn't.

      This tells me there is something in the network which is blocking the "create()" network traffic.

      To test, and to produce a simple test program for the network guys to test with, I built the Sun RMI "hello world" demo program (see http://java.sun.com/j2se/1.5.0/docs/guide/rmi/hello/hello-world.html). But when I ran this, between the non working location & the location where JBOSS is, it worked fine. (This makes some sense, as the JBOSS JNDI lookup uses RMI and this is ok, but doesn't help with the create problem).

      I'm guessing the "create()" failed because it's using different ports, or JBOSS is trying to open a port in the opposite direction when it gets the "create()" call. But I'm guessing! Hence my question above.

      Thanks

      Andrew Gonnet.


      Exception example:
      -----------------------
      java.rmi.ConnectIOException: Exception creating connection to: -.--.---.---; nested exception is:
      java.net.SocketException: Network is unreachable: connect
      at sun.rmi.transport.tcp.TCPEndpoint.newSocket(TCPEndpoint.java:587)
      at sun.rmi.transport.tcp.TCPChannel.createConnection(TCPChannel.java:185)
      at sun.rmi.transport.tcp.TCPChannel.newConnection(TCPChannel.java:171)
      at sun.rmi.server.UnicastRef.invoke(UnicastRef.java:94)
      at org.jboss.invocation.jrmp.server.JRMPInvoker_Stub.invoke(Lorg.jboss.invocation.Invocation;)Ljava.lang.Object;(Unknown Source)
      at org.jboss.invocation.jrmp.interfaces.JRMPInvokerProxy.invoke(JRMPInvokerProxy.java:119)
      at org.jboss.invocation.InvokerInterceptor.invokeInvoker(InvokerInterceptor.java:227)
      at org.jboss.invocation.InvokerInterceptor.invoke(InvokerInterceptor.java:167)
      at org.jboss.proxy.TransactionInterceptor.invoke(TransactionInterceptor.java:46)
      at org.jboss.proxy.SecurityInterceptor.invoke(SecurityInterceptor.java:55)
      at org.jboss.proxy.ejb.HomeInterceptor.invoke(HomeInterceptor.java:169)
      at org.jboss.proxy.ClientContainer.invoke(ClientContainer.java:86)
      at $Proxy0.create()Lgeogpii.copyinsp.ejb.SvrInfoRemote;(Unknown Source)
      at geogpii.copyinsp.HeartBeat.register(HeartBeat.java:102)

      I'm using:
      -----------
      Server:
      JBOSS (server) 4.0.3 SP1
      JVM JRockit 1.5.0_03
      OS MS Windows server 2003

      Client:
      JVM JRockit 1.5.0_03
      OS MS Windows server 2003
      JBOSS Client jar files from JBOSS 4.0.3 SP1 (as on the server)